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Installing QGIS 

Browse to the official website of QGIS, and find download: 

https://qgis.org/download/ 

There are three options for installing, these are: 

1. Newest  standalone version: Standalone version installs only QGIS (with the libraries it needs). 

This is the best option if you just want to run QGIS as a desktop GIS, without worrying about 

command-line tools or extra packages. It’s simpler and more self-contained — everything QGIS 

needs is bundled. I recommend installing this version. 

2. Standalone LTR version refers to a version of QGIS that is maintained for an extended period 

(typically about a year or more) with bug fixes and stability updates, but without introducing 

new features. 

3. Installing through OSGEO4W. Uses the OSGeo4W package manager. It lets you install 

QGIS and also other geospatial tools (GDAL, GRASS GIS, SAGA, etc.) in one 

environment. I recommend this for advanced users! 

What is it? 

The OSGeo4W Shell is a special command-line environment that comes with the OSGeo4W 

distribution of open-source geospatial software for Windows. 

• OSGeo4W = Open Source Geospatial Foundation for Windows:  it is an installer and package 

manager for GIS tools (like QGIS, GDAL, GRASS GIS, PROJ, MapServer, etc.) on 

Windows. 

The OSGeo4W Shell is a batch-configured command prompt (based on cmd.exe), which: 

o Automatically sets up the PATH and environment variables so GIS tools work 

correctly. 

o It lets you run command-line utilities like gdalinfo, ogr2ogr, projinfo, etc. without 

needing to manually configure Windows environment variables. 

o Can run Python with GIS bindings (e.g., GDAL/OGR’s Python modules) right away. 

o Sometimes comes in different variants: a normal shell and a shell with administrator 

privileges. 

 

Documentation 

QGIS online documentation 

https://docs.qgis.org/3.40/en/docs/index.html 

QGIS Visual Changelog – What’s new in the software 

https://qgis.org/project/visual-changelogs/  

QGIS Bug report  

https://qgis.org/resources/support/bug-reporting/ 
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Introduction to GIS 

A Geographic Information System (GIS) is a computerized system designed to facilitate the 

collection, storage, analysis, and visualization of geographically referenced data. 

The primary segment of the data seen in a GIS is its spatial component – i.e., where is it on earth? 

Each piece of data will also contain non-spatial data known as attribute data. Attribute data is generally 

defined as additional information about a spatial feature, for example, a government building. The actual 

location of the government building is the spatial data. The attribute data includes the building name, 

the number of floors in the building, the government departments that use the building, when it was 

built, etc. GIS is now commonly used in many aspects of our day-to-day lives. For example, using 

Google Maps on our phones to find an address is a type of GIS.  

The GIS has two data models, these are: vector and raster model. 

Vector data 
A representation of the world using points, lines, and polygons. Vector layers are useful for storing data 

that has discrete boundaries, such as country borders, land parcels, and streets. 

Point – a single geographical location, represented by a coordinate pair (x,y). 

Polyline – a line connecting two or more points. Each point of the lines is a node or a vertex. 

Polygon – It is an area object. This closed shape is made from line segments. Each point of the polygon 

is a node or vertex. 

Raster data 
A spatial data layer that is in the form of an image with pixels. The image is made up of equally sized 

pixels (or cells) arranged in rows and columns. Each pixel contains colors, elevations or other values. 

For example, a Digital Elevation Model (DEM) is used to represent elevation information. Scanned old 

maps contains the RGB colors of the map content. Groups of cells that share the same value represent 

the same type of geographic feature.  

 

Other terms in GIS 

Layer 
Layers are the mechanism used to store and display spatial datasets in cartography and GIS. Each layer 

relates to a specific dataset and specifies how that dataset is displayed using symbols and text labels. 

Each map created in QGIS is assembled by adding a series of layers. The two most commonly used 

types of layers are vector (feature) layers and raster layers. 

  

Attribute 
Information about a spatial feature. For example, attributes about a school may include the name, level 

of education, and number of students. Attributes are rather in use in the vector data model. 

  

CRS - Coordinate Reference System 
A Coordinate Reference System (CRS) in GIS defines how the two-dimensional map coordinates relate 

to real places on Earth. It is a mathematical description of map. It can be a geographic 

(latitudes/longitudes) or projected CRS (meters, feet etc.). 

Scale 
Map scale in GIS or cartography describes the relationship between distances on the map and the actual 

distances on the ground. 

Symbology 
Conventions or rules that define how symbols represent geographic features on a map. 

Query 
In GIS, a request to select features or records from an attributes table based on user-selected criteria, 

and to display only those features or records that meet the criteria. 

 

 



Most important vector formats 

GeoPackage (*.gpkg format) 
A GeoPackage is a standards-based, open, and platform-independent data format that stores several 

kinds of geographical data, such as raster pictures (tiles), vector features, and non-spatial tabular data, 

in a SQLite database. It is a tiny, portable, self-describing format that is perfect for offline mapping 

applications and for transmitting geographic data. Read about the format specification: 

https://www.geopackage.org/  

  

Shapefile (.shp) 
A shapefile is actually a collection of files, with the .shp file containing the feature geometry, the .shx 

file containing the index, and the .dbf file storing the attribute data. Prj or qpj contains the map 

projection, and cpg contains the character encoding. Other additional formats can contain other 

information, like a spatial index, etc. In one shapefile, one layer is stored (these can be point or line or 

polygon). Read more about the SHP specification:  

https://www.esri.com/content/dam/esrisites/sitecore-

archive/Files/Pdfs/library/whitepapers/pdfs/shapefile.pdf 

  

GPX 
A GPX file (GPS Exchange Format) is a standardized, open-source XML file used to store and share 

GPS data, such as waypoints, routes, and tracks. It contains GPS coordinates, timestamps, and other 

information, allowing users to visualize and navigate routes on a map. 

Waypoints are discrete points of interest associated with a place in GPX (GPS Exchange Format) data. 

A route is a set of arranged route points, which may also be waypoints, that specify a planned course or 

set of instructions for a future trip. Several track points, or a breadcrumb trail, that indicate the route you 

have already taken make up tracks, which are recordings of a completed voyage. 

  

GeoJSON 
Geographical features, such as points, lines, and polygons, along with their associated non-spatial 

characteristics, can be represented in plain text using a format called GeoJSON, which is based on 

JavaScript Object Notation (JSON). Web mapping and GIS applications often utilize this open standard 

for geospatial data exchange to display geographic data on a map. 

KML 

An XML-based format called a KML (Keyhole Markup Language) file describes geographic data that 

may be displayed in Earth browsers such as Google Earth and ArcGIS Earth. With the help of its 

features—which include placemarks, polygons, photos, and camera views—users may annotate maps, 

make their own geographic narratives, and visualize data in two and three dimensions. 

 

QGIS Interface 

At the first start QGIS will inherit the language of the operation system. Now, let’s set it to English. 

Language settings 
The first step is the language settings, which can be done by following the guide in the figure 

below: 

https://www.geopackage.org/
https://www.esri.com/content/dam/esrisites/sitecore-archive/Files/Pdfs/library/whitepapers/pdfs/shapefile.pdf
https://www.esri.com/content/dam/esrisites/sitecore-archive/Files/Pdfs/library/whitepapers/pdfs/shapefile.pdf


 
Restart the software to have the language settings reflected in QGIS. 

  

Familiarization with QGIS 
Right-click on the blank grey space near the top of the screen. This will open a dialog box that lets the 

user add panels and toolbars to the user interface. 

 
You will click and add two objects here: The Processing Toolbox Panel and the Manage Layers Toolbar. 

The QGIS work area has seven parts:  

• Menu Options 

• Toolbar 

• Map Canvas 

• Browser 

• Layer panel - Table of Contents 

• Processing toolbox 

• Status Bar 

 

Your QGIS should now look like this: 



 
  

Menu options 
The Menu Options bar provides access to various QGIS features using a standard hierarchical menu 

(drop-down menu). Most menu options have a corresponding tool in the Toolbar and Toolbox; however, 

the menus are not organized exactly like the toolbars and may contain additional tools. 

Toolbar 
The Toolbar provides access to most of the functions found in the menu options bar, plus additional 

tools for interacting with the map canvas. Each Toolbar item has pop-up help available. Hold your mouse 

over an item, and a short description of the tool’s purpose will be displayed. 

Map Canvas 

The Map Canvas is the main part of QGIS – this is where the maps are displayed. The map displayed in 

the window will depend on the vector and raster layers you have chosen to load (see sections that follow 

for more information on how to load layers). The Map Canvas can be panned, shifting the focus of the 

display to another part of the map. The map can also be zoomed in and out. Various other operations 

can be performed on the map using the Toolbar. The Map Canvas and the Table of Contents are tightly 

bound to each other — the maps in Map Canvas reflect changes you make in the Table of Contents area. 

Zooming the Map with the Mouse Wheel 

You can use the mouse wheel to zoom in and out on the map. Place the mouse cursor inside the map 

area and roll the wheel forward (away from you) to zoom in and backward (towards you) to zoom out. 

The zoom is centered on the mouse cursor position. 

Layer Panel (Table of Contents) 

The Table of Contents area lists all the layers in your map project. Click on a check box to turn a layer 

on or off. Double-click on a layer in the legend to customize its appearance and set other properties (e.g., 

appearance of symbols, labels). A layer can be selected and dragged up or down in the Table of Contents 

to change the Z-ordering. Z-ordering means that layers listed nearer the top of the Table of Contents are 

drawn over layers listed lower down in the Layer panel. 

Processing Toolbox 
The Processing Toolbox, which contains geoprocessing tools used for the creation and analysis of both 

vector and raster data. As mentioned before, some of these tools will also be available via the Menu 

Options. 



 
Status Bar 
The Status Bar shows you the current position of the mouse pointer in map coordinates (expressed as 

decimal degrees or meters) as well as the map scale and coordinate system. As the mouse pointer is 

moved across the map view, the coordinates will change. As you zoom in and out of the map, the scale 

will change. 

 
You should be able to change the Coordinate Reference System for your project in this status bar by 

following the guide below: 

 
In step 2 in the figure above, search for the desired Coordinate Reference System by its EPSG code, for 

example, WGS84 (Plate Carrée/equidistant cylindrical projection) has an EPSG code of 4326. This is 

the easiest way; you can also explore manual selection options. 

 

 

  



First steps with vector data 

Opening spatial data – the Data Source Manager 
QGIS supports various spatial file formats. Now, let’s see, how to import them in QGIS. The easiest 

way of opening a file is the usage of Data Source Manager. 

 
In the Data Source Manager, you can view the different drivers that QGIS supports. Each driver is 

responsible for reading and writing specific types of data sources. For instance, the OGR driver is used 

to handle vector data formats (such as Shapefiles, GeoPackage, or GeoJSON), while other drivers e.g. 

GDAL are designed for raster data, databases, or web services. 

These drivers are available from some menus, like Layer → Add layer, or from the Icon bar, or from 

Browser panel. The next image illustrates these options. 

 



 
The following windows appears while opening vectors. Add the hungary.gpkg/mo.gpkg. 

Click Add layers 

For this exercise, we will work with: 

• mo – megye (Hungarian counties) 

• mo – fout (Hungarian main connecting roads) 

• mo – folyo_felulet (Hungarian large rivers (polygons) 

• mo – telepules (Hungarian settlements) 

 
If you have successfully added a vector layer, you should see the layer in the Layer panel and an image 

on the Map Canvas, as the Figure below: 



 
  

Layer visibility, layer order 
By using the Checkbox Control: Each layer has a checkbox next to its name in the Layers Panel, which 

is often found on the left side of the QGIS interface. When the box is checked, the layer appears on the 

map canvas; when it is unchecked, it is hidden. This is explained in the guide in the figure below: 

  

 

Setting layer order 

To change the order, simply click and drag a layer to your desired position in the Layers Panel. For 

example, you might want point layers (e.g., Hungarian settlements) to appear above polygon layers (e.g., 

Hungarian counties) to ensure they are visible. Follow the guide in the figure below: 



 
 

Feature count 
In QGIS, the „Show Feature Count” option allows you to display the number of features in a vector 

layer directly in the Layers Panel. This is useful for quickly assessing data volume and distribution. 

Here’s how to enable and use this feature: 

Enabling Feature Count in the Layers Panel 

1. Right-click on a vector layer in the Layers Panel. 

2. Select Show Feature Count from the context menu. 

3. The total number of features in the layer will appear next to the layer name. 

 
 

Identify features 
Identify features query the data of the selected feature from the attribute table. Before you identify the 

feature, set the focus on the desired layer in the layer panel. 



 
 

Attribute table 
In QGIS, the attribute table is a tabular view that shows the non-spatial information (attributes) 

associated with your spatial data (points, lines, polygons, or raster cells with 

categories). 

Each row is one feature (e.g., a city, a road, a land parcel). 

• Each column (field) corresponds to one attribute (e.g., name, population, length, area, soil 

type). 

• The first column usually contains the unique ID (FID/ID) for features. 

• You can sort, filter, and query attributes directly. 

• Attribute values can be edited if the layer is editable. 

QGIS offers querying from attribute table using a SQL-like query language. 

To open attribute table, right-click on layer name → Open Attribute table, or use the Tabular like icon 

on icon Bar. 

 

 



Point symbology 

Basic Point Symbology 
This chapter focuses on points symbology with the following tools: simple marker, ellipse marker, font 

marker, SVG marker. 

Simple Marker 
The most basic point symbol is a simple marker (e.g., circle, square, triangle). You can change its color, 

size, rotation, and outline properties. 

How to: 

Add point data in QGIS through data source manager as described in the figure below: 

 
Open the Layer Styling Panel (or Layer Properties → Symbology), choose Simple Marker, and adjust 

the settings. Follow the guide in the figure below: 

 
Note that the following parameter must be set for a Cartographic visualization of a point symbol: 

1. Size 



2. Fill color 

3. Stroke style 

4. Stroke width 

5. Stroke color 

If you choose a cross symbol at this stage you will see something like the figure below: 

 

The Ellipse Marker  
The Ellipse Marker is a flexible symbol layer type in QGIS that is used to style point features.  By 

modifying its features, you can produce not only ellipses but also other forms like circles, rectangles, 

and crosses. To set up an Ellipse Marker, open the Symbology: Right-click a point layer in the Layers 

Panel → Properties → Symbology. 

• In the Symbol Layers Tree, select the existing symbol layer or click Add Symbol Layer. 

• Change the Symbol Layer Type to Ellipse Marker. 

• Adjust Properties: 

• Size: Set width and height in units like millimeters, pixels, or map units. The main difference 

of ellipse marker from the simple marker is this option, the size can be defined by two 

parameters, not only one. 

• Style: Configure fill, stroke, and join/cap styles, same as simple marker. 

• Rotation: Use a fixed angle or data-defined expression (e.g., to align with wind direction) 



This can be done by following the guide in the figure below:

 
At this stage you will see something like the figure below if you select an ellipse: 

 

SVG Markers  
Point features on your map can be represented using scalable vector graphics with SVG markers in 

QGIS.  This offers high-quality visuals at different zoom settings, flexibility, and personalization. 

To apply an SVG marker to a point layer, Open Layer Properties → Symbology. 

• Change the Symbol Layer Type to SVG Marker. 

• In the SVG Browser, select your desired SVG symbol. These symbols are organized into groups. 

It is also possible to add your own symbol. 

• Adjust properties like Size, Rotation, Fill Color, and Stroke Color as needed. 



 
 

Font Marker symbol 
Characters from font files can be used as point symbols using QGIS’s Font Marker symbol layer type. 

This makes it possible to create markers that are incredibly configurable, scalable, and visually 

consistent, like icons from Webdings, Font Awesome, or other symbol fonts. You can define the font 

family, font style and size, fill color, etc. 

To set up a Font Marker, follow the guide in the figure below: 



 

Advanced Symbology 

Advanced point symbols in QGIS 
Advanced point symbols in QGIS let you produce detailed, visually compelling, significant point data 

representations. These allow you to construct multi-layered, data-driven, and personalized symbols, 

going much beyond basic dots or circles. 

 

In QGIS, you will need to use multiple symbol layers to construct a combination of symbols, for 

example a Font Marker inside a circular symbol. This is an effective method for creating unique point 

symbols, like enclosing a character or icon in a circle. To do this, follow the following guide: 

1.      Open the Layer Styling Panel. Right-click your point layer in the Layers Panel and select 

Properties → Symbology. 

2.      Add a Circle (Simple Marker) as the Base Layer 

By default, QGIS uses a Simple Marker. If not, click Simple Marker to open the Symbol Selector. 

Configure the circle: 

• Symbol Layer Type: Ensure it is set to Simple Marker. 

• Shape: Choose the Circle. 

• Size: Set the diameter of the circle (e.g., 4.0 millimeters). 

• Fill color: Choose the interior color of the circle. 

• Stroke color: Set the border color (if desired). 

• Stroke width: Adjust the border thickness 

• Click on the green plus (right side of the window) 

• Add Font marker and change it to letter S 

• Change symbol order for Font S to be on top of a Circle 

You will be able to see something like the figure below: 



 

Exercise 1 
Next stage we will exercise the procedures to construct a symbol that looks like the figure below: 

 
This symbol can symbolize the country with its short name code in a road map. 

1. Access Layer Styling: 

o Right-click on your point layer in the Layers Panel and select Properties. 

o Go to the Symbology tab  

2. Choose an Simple Marker Symbol: 

o By default, QGIS uses a Simple Marker. Click on the Simple Marker entry under 

the Symbol section to open the Symbol Selector  

3. Change Marker to Ellipse: 

• In the Symbol Selector, find the Symbol layer type dropdown and change it from Simple 

Marker to Ellipse Marker  

• This type of marker allows you to define precise dimensions. 

Configure the ellipse (Yellow Fill): 

• Width: Set the width to 5 mm. 

• Height: Set the height to 3 mm. 

• Fill Color: Click on the color next to Fill color and choose yellow. 

• Stroke Style: You can set the Stroke color to transparent or a desired outline color. If no outline 

is needed, set the stroke style to No Pen 

Add the "HU" Inscription: 

• The text is a separate symbol layer. Click the Add Symbol Layer button (+) in the Symbol 

Selector  

• Change the new layer's Symbol layer type to Font Marker. 

• Font: Choose a clear, bold font (e.g., Arial Black). 

• Character(s): Enter HU. 

• Size: Set the size to 4.0 mm. 

• Color: Set the color to black. 

Adjust Layer Order (If Necessary): 

• In the Symbol Layers panel, ensure the Font Marker layer is above the Ellipse Marker layer. 

You can drag layers to reorder them. The text should be on top of the ellipse 

At this stage you will see something like the figure below: 



 

Exercise 2 
In the next practice, the following symbol will be constructed: 

 
This symbol can mark an important city in a political map. 

1. Open the Layer Properties: 

• Right-click your point layer in the Layers Panel. 

• Choose "Properties". 

• Go to the "Symbology" tab. 

2. Base Symbol Type: 

• Make sure the symbol type is set to "Simple Marker". 

 

Add the Three Symbol Layers 

1. Black Filled Square 

• Click the "+" (Add symbol layer) button at the bottom. 

• Choose "Simple marker". 

• Set: 

o Shape: Square 

o Size: 5 mm 

o Fill color: Black 

o Outline style: No pen (or transparent) 

2. Red Circle 

• Click "+" again to add a new symbol layer. 

• Choose "Simple marker". 

• Set: 

o Shape: Circle 

o Size: 4 mm 

o Fill color: Red 

o Outline style: No pen 

3. 45° Rotated Black Cross 

• Click "+" again to add a third symbol layer. 

• Choose "Simple marker". 

• Set: 



o Shape: Cross 

o Size: 5 mm 

o Stroke width: 0.2 mm 

o Color: Black 

o Rotation: 45° 

At this stage you will something like the figure below: 

 

Line Symbology 

„Double” line map element 
In QGIS, double line map symbology is commonly used to represent features such as roads with 

medians, railways, boundaries, or any linear features that require a symbol with two overlapping 

parallel lines. Here’s an overview of how to set up double line symbology for linear elements in QGIS. 

For this exercise we will import Hungarian main connecting roads (mo-fout). This layer is stored in the 

Hungarian dataset Geopackage (mo.gpkg). 

Creating Double Line Symbology in QGIS 
Steps 

1. Select your layer in the Layers panel. 

2. Open the Layer Properties: 

• Right-click the layer → Properties → Symbology. 

3. Change the Render type to Symbol layer type: “Line” (if it isn't already). 

4. Click on the “+” button to add multiple symbol layers. 

• You'll need two symbol layers for a double line: 

o One for the outer line (e.g., a wider colored line), 

o One for the inner line (e.g., a thinner white or black line to simulate the center). 

o Adjust the widths: 

▪ Set the bottom layer (e.g., the "outline") to be wider. 

▪ Set the top layer (e.g., the "inner" line) to be narrower. 

5. Set outer lines to red color, 1 mm width, set yellow color for the inner line 1.5 mm. 

At this stage you will see something like the figure below: 



 
Make sure that lines join smoothly at intersections without one symbol layer overlapping the other one 

awkwardly. Use Symbol levels (click on the line in the line symbol tree, and find Advanced settings 

below window of predefined symbols. Enable the symbol levels. Now, the line ends are not intersected 

in the line. It has to look like the figure below: 

 
 

Three-line symbology 
To create a three-line road symbol in QGIS (e.g., for a motorway with blue outer lines, a white inner 

line, and a thin center line), follow these steps using layered line symbols: 

• One Blue outer lines: 2 mm wide 

• White inner line: 2 mm wide 

• Thin center line: 0.1 mm wide 

To construct this, follow the procedure below: 

• Select your line layer in the Layers Panel. 

• Right-click the layer → Properties → go to the Symbology tab. 

• Set Symbol type to "Line" if not already set. 

• You'll now build a symbol stack of three lines: 



 

Add Symbol Layers 

 1. Outer Blue Line 

• Click "Add symbol layer" (+ icon below the symbol preview). 

• In the new layer: 

o Set Color: Blue 

o Set Stroke width: 2 mm 

o Leave Offset: 0 (centered) 

2. Inner White Line 

• Add another symbol layer (now you have 3). 

• Move it above the blue line (use the up arrow). 

• In this layer: 

o Set Color: White 

o Set Stroke width: 2 mm 

o Offset: 0 (also centered) 

o Thin Center Line 

Add a third symbol layer. 

• Move it to the top of the stack. Set: 

o Color: Black (or any desired centerline color) 

o Stroke width: 0.1 mm 

o Offset: 0 

At this stage you will see something like the figure below: 

 
Use the Preview to check the appearance. Click Apply then OK to save the style. 

  

Dotted line symbol 
To create a dotted line symbol in QGIS — with 2 mm dots spaced 5 mm apart — you can do this using 

the “Marker Line” symbol layer type. Marker lines are those lines, where the line represented by 

markers. Here’s how to set it up: 

1. Select your line layer in the Layers Panel. 

2. Right-click → Properties → go to the Symbology tab. 

3. At the top, set the symbol layer type to “Line”, if not already. 

4. Click the “+” icon (Add symbol layer) → choose “Marker Line” as the new layer type. 

In the Marker Line options: 

• Placement: set to “Interval”. Interval: 5 mm (this controls the spacing between the dots) 

5. Marker Symbol 



Click the marker symbol to edit it: 

• Set the symbol to a “Simple marker” 

• Shape: Circle 

• Size: 2 mm 

• Fill color: your desired dot color (e.g., black) 

 At this stage you will see something like the figure below. 

Click Apply and OK to save and preview the style on your map. 

 

 
 

Symbolizing a railway feature 
For this exercise we will use Hungarian railways (mo-vasut). 

To create a railway line symbology in QGIS with a line thickness of 0.2 mm, you can start with a 

simple solid line — but for a more realistic railway symbol (e.g. showing tracks or sleepers), QGIS 

allows advanced customization using Marker Line symbology. 

Use combined Symbol Layers: 

1. Start with the base line: 

• Symbol type: Line 

• Set stroke width: e.g., 0.4 mm (rail thickness) 

• Color: Dark gray or black 

2. Add cross ties (sleepers): 

• Click “+” to add a new symbol layer 

• Change it to “Marker Line” 

• Select a „line” marker in new "Marker line" symbol. 

 

In Marker Line settings: 

• Placement: Interval 

• Interval: e.g., 3 mm (distance between sleepers) 

At this stage you will see something like the figure below: 



 

 

Railway symbol with a white, dashed center line over a thicker gray/black base 
1. Open Symbology 

• Right-click your railway line layer → Properties → Symbology. 

2. Set up the bottom (black) line 

• Make sure the symbol type is “Line”. 

• Set: 

o Color: Black 

o Stroke width: 1 mm 

3. Add the top (white) line 

• Click the “+” icon below the symbol preview to add a new symbol layer. 

• Move this new layer above the black one (use the up arrow). 

• Set: 

o Color: White 

o Stroke style dashed line. You also can use the Custom dash pattern. In this window you 

can set the length of the dashed section and the length of the space. 

o Stroke width: 0.5 mm 

Don’t forget to activate the Symbol levels in the earlier mentioned way! 

At this stage you will see something like the figure below: 



 

Polygon Symbology 

Simple fill settings 

Simple fill with a dashed outline 
For this exercise we will use Hungarian counties layer (mo-megye). Add Hungarian counties layer in 

QGIS.  

• Right-click your polygon layer in the Layers panel → Select “Properties” 

• Go to the “Symbology” tab. 

• Under Symbol Layers, select or ensure the symbol type is “Simple fill” 

• Adjust the settings: 

o Fill style: Choose any fill (e.g., Solid) or No Brush if you want no fill. 

o Stroke style: Change from Solid Line to Dashed Line 

o Stroke width: Adjust line thickness as needed 

o Color: Choose your desired outline color 

Click “OK” to apply the changes. 



 
  

Point pattern fill 
In QGIS, setting a Point Fill is typically used when you want to fill a polygon with a repeating point 

symbol, rather than a solid color or hatch pattern. 

This is useful for things like symbol patterns inside polygons (e.g., dots, crosses, etc.), and it's done 

using a “Point pattern fill” in the symbology settings. 

1. Right-click your polygon layer → Select “Properties” 

2. Go to the “Symbology” tab. 

3. First add one symbol and set it to simple fill, color set yellow, re-order the symbol order. 

4. Then select top symbol. 

5. At the top, where it says “Single Symbol”, click the dropdown and choose: 

„Point pattern fill” 

• A new set of options appears: 

o Point symbol: Choose the symbol you want to repeat inside the polygon (e.g., circle, 

square, cross) 

o Distance X / Y: Set the spacing between points (horizontal and vertical) 

o Offset X / Y: Adjusts the pattern’s position 

o Angle: Rotates the point fill pattern 

o Clip points to polygon boundary: Keeps symbols inside the polygon only 

• Customize the Point symbol: 

o Click the symbol preview box (next to “Point”) 

o This opens the Symbol Selector 

o You can change the shape, size, color, outline, etc. 

• Click “OK” to apply your styling. 



 
  

Line pattern fill 
In QGIS, the Line Pattern Fill is used to fill polygons with repeated parallel lines — useful for hatching, 

shading, or cartographic styles like zoning, geology maps, etc. 

How to Set a Line Pattern Fill in QGIS 

1. Right-click your polygon layer → choose “Properties” 

2. Go to the “Symbology” tab 

3. First add one symbol and set it to simple fill, color set yellow, re-order the symbol order. 

4. Then select top symbol. 

5. In the top dropdown (usually says “Single Symbol”), choose: “Line pattern fill”  

6. Main Settings: 

• Line symbol: Click this to edit the style of the lines (e.g., dashed, color, width) 

• Angle: Controls the rotation of the lines (e.g., 45° for diagonal hatching) 

• Spacing: Distance between lines (e.g., 5 mm) 

• Offset: Shifts the whole pattern left/right 

• Clip lines to polygon boundary: Ensures lines stay inside the shape 

7. Click OK to apply the style. 

At this stage you will see something like the figure below: 



 
  

SVG fill 
In QGIS, an SVG Fill allows you to fill a polygon with a repeating SVG image or pattern, such as 

textures, hatching, symbols, or custom designs. It’s ideal for creating rich cartographic effects like 

geology patterns, zoning textures, or decorative maps. 

1. Open Layer Properties 

• Right-click your polygon layer → select “Properties” 

• Go to the “Symbology” tab 

First add one symbol and set it to simple fill, color set yellow, re-order the symbol order. 

1. Then select top symbol. 

2. Change the symbol layer type to: "SVG Fill" 

Customize the following on the SVG symbol: 

• Width/Height 

• Angle 

• Offset X, Y 

• Color 

• Stroke 

Click OK to apply the style. 

 

Why do not use this type of Symbology? 

In SVG fill, you can not set the distance between the pattern symbols. You can set only the size of the 

SVG symbol.  

What to use instead? 

Use point pattern fill with SVG symbol, it allows much better the customization of sizes. 

At this stage you will see something like the figure below: 



 
 

Vineyard/cemetery symbol 
To set Grape or Vineyard symbol in QGIS, you can do it in a few different ways depending on what you 

want. This can be done by using the combination of point pattern as Font Marker and Simple Fill symbol,  

this can be done by following the guide in the figure below: 

 
It is possible to use the same procedure and change Font Marker to Simple Marker and select a cross 

sign to make the symbol look like Cemeteries symbology. Don’t forget what you learned at Point pattern 

fills: you can set the distance between the elements of the pattern. 

 

Centroid fill 
In QGIS, a Centroid Fill is a style that places a symbol at the centroid (center) of each polygon — very 

useful for labeling, symbols like point. 

  

• Right-click your polygon layer → choose “Properties” 

• Go to the “Symbology” tab 

• Click the “+” (Add symbol layer) button (bottom-left) 



• Add the Centroid fill. If the polygon shape is rather concave, sometimes the centroid may be 

outside of the polygon. Force placement of markers inside polygon checkbox always improve 

the placement inside of the shape. 

 
 

Outline: Simple line 
For example, if you create a line or point pattern fill, the polygons do not have outlines. To indicate the 

area boundaries, it is worth to add the outline as a simple line. 

• Right-click your polygon layer → choose “Properties” 

• Go to the “Symbology” tab 

• Click the “+” (Add symbol layer) button (bottom-left) 

• In the new symbol layer, click the dropdown arrow to select "Outline: Simple line 

Make sure the bottom simple fill polygon has "no line stroke style". 

Click “OK” to apply the changes. 

 
 



Marker line 
Marker lines are lines built from markers. The disadvantage of the application of marker lines are, the 

neighboring polygon’s outlines are overlapping each other, thus at the borders there are overlapping, 

duplicated symbols. 

To set symbol in QGIS, 

• Right-click your polygon layer → Select “Properties” 

• Go to the “Symbology” tab 

• Click the "+" (Add symbol layer) button 

• From the dropdown, choose “Outline: Marker Line” 

Click “OK” to apply the changes. 

At this stage you will see something like the figure below: 

 
  

Note: Why Shape burst and Gradient fills are not recommended in thematic mapping: 

1. They do not communicate data clearly 

• Thematic maps aim to visually represent attribute data (like population, land use, temperature). 

• Gradient and shape burst fills create visual effects (e.g., smooth color changes or inner glows) 

that are not linked to data values. 

• This can confuse map readers into thinking the gradient represents something quantitative. 

Example: A polygon filled with a radial gradient might appear to show a "hotspot" in the center — even 

if there is no such data. 

2. They distort visual perception 

• Gradients can create the illusion of depth, focus, or intensity, even if that’s not intended. 

• The human eye interprets shading as elevation or density, which can mislead the viewer. 

People might think: 

“The middle of this polygon has higher values,” even if the fill is purely decorative. 

3. Not data-driven 

• The fills are based on geometry (shape/size), not on the attribute table. 

• The result is a map where all features may look similar, regardless of the data you're mapping. 

This contradicts the purpose of thematic mapping, where color or symbol variations should reflect actual 

data differences. 

4. And finally, the most important aspect: they reduce map readability! 

• Shapeburst and gradient fills can: 

o Make labels harder to read 

o Clash with base maps or other layers 

o Reduce overall contrast and clarity 



Categorized symbology 

Visualizing line layers by their attributes 
To visualize a railway layer in QGIS based on their status attribute (e.g., active, inactive, under 

construction), you can use categorized symbology. This lets you apply different styles (colors, line types, 

widths, etc.) depending on the value of the status field in your attribute table. 

Step-by-Step: Categorize Railways by Status 

1. Open the Layer Properties 

• In the Layers Panel, right-click your railway line layer → click Properties. 

• Go to the Symbology tab. 

2. Change to Categorized Renderer 

• At the top, set the "Render type" to “Categorized”. 

• Column: Choose your status attribute 

3. Classify the Status Values 

• Click the “Classify” button. 

• QGIS will scan the status field and add a category for each unique value (e.g., Active, Inactive, 

Abandoned, Planned, etc.). 

Click the symbol next to each category to: 

• Adjust line color 

• Set line width 

• Choose dash or dot patterns 

At this stage you will see something like the figure below: 

 
 

Graduated symbology 

Visualizing river layer by their length 
We are going to visualize Hungarian water ways by their length in the following exercise. 

1. First add (mo-patak), Hungarian water ways in QGIS. 

2. This layer does not have a length as an attribute yet, we are going to create and calculate this 

attribute as a new field (column), to do this follow the following steps: 

Open Attribute Table 

• Right-click the layer in the Layers Panel → Open Attribute Table. 



Open Field Calculator 

• Click the Field Calculator icon (looks like a calculator) 

Create New Length Field 

In the Field Calculator dialog: 

Field Definition: 

• Check: “Create a new field” 

• Output field name: length_m (or length_km, depending on your preference) 

• Output field type: Decimal number (real) 

Field Length Options (optional but good practice): 

• Length: 10 

• Precision: 2 (for 2 decimal places) 

In the Geometry expression builder select $length, at this stage you will see something like the figure 

below: 

 
Now you will have a new column named length, we will use this attribute to visualize this layer. 

 To visualize water ways by their length follow the procedure below: 

Open Symbology Settings 

• Right-click your waterways layer → Properties → Symbology tab 

Choose Graduated Symbology 

• At the top, change “Single Symbol” to “Graduated”. 

In the Graduated panel: 

• Column: Choose your length field (e.g., length_m) 

• Method: Choose how to divide values into groups: 

o Equal Interval – evenly spaced length ranges 

o Quantile (Equal Count) – same number of features per class 

o Natural Breaks (Jenks) – based on data distribution 

• Classes: Choose how many classes (e.g. 5) 

Style the Symbols 

You can control how features appear by length: 

Line width 

• Click the symbol beside each class. 

• Change the line width for each class to increase progressively. 

o Example: 

▪ Class 1: 0.3 mm 

▪ Class 2: 0.6 mm 

▪ Class 3: 1.0 mm 



▪ Class 4: 1.5 mm 

▪ Class 5: 2.0 mm 

Apply and View 

• Click Classify to generate classes. 

• Then click Apply and OK. 

You’ll now see the waterways styled based on their length — longer rivers might be thicker and darker, 

shorter streams thinner and lighter. 

 
 

Categorized point symbology 
Categorized point symbology in QGIS is a method of symbolizing point features based on the unique 

values of an attribute field. It helps to visually distinguish features based on categories like type, status, 

or classification. 

In this exercise, we are going to use Tourist attractions.gpkg file.  

In this exercise, we are going to create categorized point symbology from Tourist attractions points 

datasets, collected in Dodoma region, Tanzania. These data have the following attributes: 

1. Description 

2. Additional description 

3. Name 

The goal is create categorized symbols based on their names. 

To do this in QGIS follow the following steps: 

Here’s a step-by-step guide: 

1. Open Layer Properties 

• Right-click your point layer in the Layers Panel 

• Click Properties 

• Go to the Symbology tab 

2. Change the Render Type 

• In the top dropdown (labeled "Render type"), select Categorized 

3. Select the Categorizing Field 

• Choose the attribute field to base the categorization on (Name) 

4. Classify 

• Click the "Classify" button 

• QGIS will generate a list of unique values from the field and assign random symbols/colors 

At this stage, you will see something like the figure below: 



 
Next stage is to change every point feature from simple marker to SVG marker that resembles its 

cartographic representation, for example hospital with a hospital symbol. This is already discussed in 

Module 2. 

Click a symbol and follow the following procedure: 

Change Symbol Type 

• In the symbol window, click on the current symbol (Simple marker) to open the Symbol Selector 

• In the "Symbol layer type" dropdown (top left), select "SVG Marker" Choose an SVG Symbol 

• Click the "SVG Image" dropdown 

• Browse through categories like: 

o Basic shapes 

o Transport 

o Arrows 

o Others depending on your system or installed SVGs 

5. Customize the SVG 

You can change: 

• Size 

• Rotation 

• Color (if the SVG supports fill/outline changes) 

• Offset (to nudge symbols) 

Note: Some SVGs may not respond to color changes if they’re not designed with editable properties. 

5. Apply and Close 

• Click OK to apply the SVG marker 

At this stage, you will see something like the figure below: 



 
Repeat the procedures until all symbols are properly customized. 

 

Graduated Symbology of settlement layer based on number of the population 
In QGIS categorized symbology is a powerful feature that allows you to visualize vector data by 

assigning distinct symbols (colors, shapes, or patterns) to features based on unique values in a specified 

attribute field.  

In this exercise, we will visualize Hungarian settlements (mo-telepules), by population 

(nepesseg_2018). 

1. Open the Layer Styling Panel: Select your settlements layer in the Layers Panel. Go to Layer → 

Properties → Symbology, or simply press F7 to open the Styling panel directly. 

2. Change Symbology Type: At the top of the dialog, click the dropdown menu that says „Single 

Symbol” and change it to „Graduated”, method select Size. 

3. Choose the Population Column: In the new dialog, next to „Value”, click the dropdown and 

select the attribute field that contains the population data (nepesseg_2018). 

For classification mode, select equal counts for now, and number of classes select 5. 

At this stage, you will see something like the figure below: 

 



Next stage is to change symbol for every population category, this can be done by following the guide 

that follows: 

After having the graduated symbols then click on each symbol to customize its style by following the 

previous discussed methods on how to change symbols (advanced point symbology). 

 
Additionally, in the Classes list, you can set how many groups to create. If we do not define the category 

boundaries ourselves, then the automatic classification option (Mode) must be selected. 

There are five options: 

a) Equal Intervals: The method of equal intervals. The size of the intervals is the same. 

b) Quantile (Equal Count): Equal count. Each interval contains the same number of elements. 

c) Natural Breaks (Jenks): The Jenks natural breaks method. It finds the gaps in the dataset, and these 

gaps will be the bounds of categories. 

d) Standard Deviation: Based on normal distribution. 

e) Pretty Breaks: An algorithm from the R language, which creates „pretty” edges of all categories 

By clicking the Classify button, the data can be automatically grouped into classes. By clicking the 

symbol in front of the groups, the appearance of the symbol can be defined. 

 

Graduated symbology of polygon layers 
In this Module, we are going to address the following: 

1. Create a population density map using county layer (lakos_2018-population) attribute. 

2. The area of the county has to be calculated first in Field calculator - $area function.  

3. After that calculate the population density in a new field.  

4. Use Graduated Symbology to visualize these data. Explain what these classification methods 

are:  Equal Count, Equal Interval, Natural Breaks, Pretty Breaks.  

5. Coloring what are the recommended colors for a population density map? 

  

Step-by-Step Instructions to create population density map 

1. Load the County Layer 

• Load your county polygon layer into QGIS (mo-megye from mo.gpkg). 

• The layer contains a population attribute — in your case, it’s lakos_2018. 

2. Open the Attribute Table 

• Right-click on the county layer → Click "Open Attribute Table" 

3. Calculate County Area 

You’ll calculate area in square kilometers. 

Use Field Calculator: 

• Click the Field Calculator icon (abacus symbol) 



• Create a new field: 

o Name: area_km2 

o Output field type: Decimal (real) 

o Output field length: e.g. 10,3 

• In the expression box, enter: 

$area / 1000000  

This converts the area from square meters (default geometry unit of the layer, because the unit of 

Hungarian EOV is meter.) to square kilometers.  

• Click OK — the new field area_km2 is added. 

 
4. Calculate Population Density 

Now, you’ll divide population by area. 

Use Field Calculator Again: 

• Open Field Calculator 

• Create a new field: 

o Name: pop_density 

o Output field type: Decimal (real) 

o Output field length: e.g. 10,3 

• Expression:  "lakos_2018" / "area_km2" 

• Click OK — the new field pop_density is added. 

At this stage, you will see something like the figure below: 



 
5. Style the Map Using Population Density 

Apply Graduated Symbology: 

• Right-click the county layer → Properties → Symbology 

• In the top drop-down, choose Graduated 

• Set the value to: pop_density 

• Choose a color ramp (e.g. Yellow to Red) 

• Choose a classification mode (e.g. Jenks Quantile) 

• Click Classify, then Apply 

Now, your map shows population density with graduated colors — darker or more intense colors for 

higher density. At this point, you will see something like the figure below: 

 
 

In QGIS, when you apply graduated symbology to a field (e.g., population density), you need to divide 

your data into classes to visualize patterns. The way QGIS groups the data depends on the 

classification method you choose. 

1. Equal Interval: Divides the range (max - min) into equal-sized intervals. Values are evenly 

spread across the range. Easy to interpret but may be misleading with skewed data. 



2. Equal Count (Quantile): Each class has the same number of features. Values are not evenly 

distributed. 

3. Natural Breaks (Jenks): Finds "natural" groupings in the data. Data has clusters or gaps. 

Highlights real patterns in the data. 

4. Standard Deviation: Classes based on how far values are from the mean.  Suitable if you want 

to highlight deviations from the average. It assumes data is normally distributed. 

5. Pretty Breaks: Rounds class boundaries to "nice" values (like 10, 100, etc.). For making maps 

more readable, Clean, rounded labels. Values are evenly spread across the range. 

6. Logarithmic Scale: Uses a log scale to handle extreme values. Data is highly skewed (some 

huge values), Compresses large values. 

7. Custom: You set the class breaks manually, used when you know exactly how you want the 

data divided. Requires knowledge of the data. 

Key take away notes: 

Why „YlOrRd” or very similar color ramp is recommended for Population Density Maps? 

1. Intuitive Progression from Low to High 

• The ramp starts with light yellow (low values), moves through orange, and ends with deep red 

(high values). 

• This mirrors how people naturally interpret colors: 

o Yellow = safe, small, low 

o Red = danger, intensity, high 

So when users see dark red, they instantly understand it means "high population density." 

2. Sequential and Perceptually Clear 

• „YlOrRd” is a sequential ramp, ideal for continuous data like population density. 

• The color changes are gradual and perceptually uniform, making it easy to see the differences 

between class values. 

3. Visually Engaging and High Contrast 

• Bright yellows stand out well on white or light basemaps. 

• Deep reds provide strong contrast, highlighting areas of high concern or interest (e.g., urban 

centers). 

• This creates a visually striking map that grabs attention while being informative. 

4. Common and Recognized in Thematic Mapping 

• Widely used in: 

o Government reports 

o Academic maps 

o Health, risk, and population studies 

• Viewers are already familiar with this color scheme, which reduces confusion. 

 

Supporting literatures: 

1. https://doi.org/10.1167/jov.20.12.7 

(https://jov.arvojournals.org/article.aspx?articleid=2771967&) 

2. https://link.springer.com/article/10.1007/s42489-024-00171-z 

 

Simple labels 

Display Single labels of the point 
In QGIS, the "Display Single Labels" option is a labeling method used to display text labels for point 

features (but it also applies to lines and polygons). 

For this exercise, we will use mo.gpkg and add mo-telepules (Hungarian settlements layer).  

To do this, follow the following steps: 

1. Open Layer Properties 

• In the Layers Panel, right-click your point layer 

• Choose “Properties” 

https://doi.org/10.1167/jov.20.12.7
https://jov.arvojournals.org/article.aspx?articleid=2771967&
https://link.springer.com/article/10.1007/s42489-024-00171-z


• Go to the “Labels” tab on the left 

2.Enable Labeling 

• At the top, select: 

o "Single labels" (from the drop-down) 

• Under “Value”, select the attribute field you want to show (e.g., "name"). 

3. Customize Label Appearance  

• Font and size 

• Color 

• Buffer (outline around text) 

• Placement: for point layer we select Cartographic.  

o What are the advantages of cartographic placement? 

Cartographic placement tries to avoid overlapping labels with symbols or other labels, 

so the map remains clear. 

o It follows well-established cartographic conventions (e.g., placing labels above and to 

the right of points, what is usually easiest to read). 

o The algorithm evaluates multiple candidate positions (top-right, top-left, bottom-right, 

bottom-left, directly above, directly below, etc.) and selects the best one. 

o This reduces clutter and improves the visual balance of labels. 

o Use the from Symbol bounds option. It guarantees, that the symbol does not overlap 

with the label. 

At this stage, you will see something like the figure below: 

 
Apply and View 

• Click Apply and then OK 

• Labels will now appear — one per point feature — on your map 

General settings 
1. Text 

This section controls what gets displayed and the basic appearance of the label: 

• Value: Choose the field or expression to show (e.g., "name" or "population"). 

• Font: Set font type, size, and style (bold, italic, etc.). 

• Color: Set the label text color. 

• Opacity: Make the label more or less transparent. 

• Blend mode: Determines how the label blends with the map underneath (e.g., normal, multiply). 

2. Formatting 

This section affects how the text is displayed, especially if it's long: 



• Wrap on character: Automatically breaks the label onto multiple lines at a specified character 

(e.g., space). 

• Multiline alignment: Aligns wrapped text to the left, center, or right. 

• Line height: Adjusts vertical spacing between lines. 

• Text styling: You can set bold, italic, underline, and even apply data-driven formatting using 

expressions. 

3. Buffer 

The buffer is an outline (or halo) around your text to make it stand out from the background: 

• Enable buffer: Turns the outline on or off. 

• Size: How thick the outline is (usually 1–2 mm is enough). 

• Color: The outline color (commonly white or black for contrast). 

• Join style: Controls how corners of the buffer are drawn (rounded, sharp, etc.). 

• Opacity: You can make the buffer semi-transparent if needed. 

Why use a buffer? 

It improves label readability over complex backgrounds like satellite imagery or dense vector layers. 

4. Rendering 

This section controls how labels behave when there’s potential for overlap or conflict: 

• Label every part of multipart features: Labels each part of a multipart geometry (not usually 

used with points). 

• Limit number of features to be labeled: Restricts how many labels are shown for performance 

or clarity. 

• Show all labels (including overlapping): Forces QGIS to display all labels even if they overlap 

— useful in dense maps. 

• Z-index: Controls the drawing order of labels. Higher Z-index values are drawn on top of lower 

ones. Essential when labeling multiple layers to make sure important labels stay on top. 

These settings can be configured by following the guide below: 

 
Note: If labels overlap too much, consider adjusting: 

• Label placement (around or offset from point) 

• Label priority (found under “Rendering”) 

• Use data-defined overrides to show/hide labels based on zoom level or other conditions 

Labelling for line layers  
Placement: curved/parallel 

In this exercise, we are going to label Hungarian main river by following these criteria. 

To do this follow the following steps: 

To set up curved or parallel labeling for your river layer (folyo_vonal layer), follow these steps: 



First add folyo_vonal layer form the geopackage mo.gpkg, 

1. Open the Label Settings: Double-click your folyo layer to open Layer Properties. Go to 

the Labels tab, and set the method to Single Labels. Choose the attribute field that contains the 

river names (e.g., „name”). 

2. Configure Placement: 

o Navigate to the Placement section. 

o Set Mode to  Curved (to follow the river's bends)   

o Under Allowed positions, you can choose Above line, On line, and/or Below line based 

on your cartographic preference. 

 
Click apply and OK. 

 

Why curved labeling is a fundamental rule in cartography for river line? 

A river is a dynamic, flowing, natural feature. Its path is rarely straight. A curved label directly mirrors 

this physical characteristic. 

• Visual Metaphor: The flowing text acts as a visual metaphor for flowing water. A map reader 

can instantly understand the river's sinuous path just by glancing at the label's shape. 

• Straight Label Problem: A straight or parallel label placed on a winding river can be visually 

confusing. It creates a geometric, rigid element that clashes with the natural form of the feature, 

potentially making the path of the river harder to trace. 

• Follow the Line: When a label curves along with the river, it helps the map user follow the 

river's course, especially through complex areas with many other features. The text itself 

highlights the path. 

• Prevents Ambiguity: On a highly meandering river, a straight label might be placed over a 

section that runs relatively straight, but this doesn't indicate what happens upstream or 

downstream. The curved label ensures the label is associated with the entire visible segment it 

labels. 

• Fits the Available Space: A long river name can be fit into a tight, meandering valley by 

curving it to follow the river's bend. A straight label would need a long, clear, straight-line space 

that simply doesn't exist in the terrain. 

• Avoids Conflicts: By conforming to the river, the label is less likely to collide with other 

important map symbols (like towns, roads, or contour lines) that might be located in the adjacent 

space. 

  

Labelling a road network with number of roads with background (rectangle etc.) 
In this exercise we are going to use Hungarian main connecting road network layer (mo-fout.shp) from 

mo.gpkg 



Add mo – fout in QGIS, 

1. Enable Labeling: Select your mo-fout.shp layer in the Layers Panel. Go to the properties tab, 

and click Labels tab. Select Single label option. 

2. Select the Value Field: In the Value dropdown, choose the attribute field that contains the road 

numbers you want to display  

3. Format the Text: Navigate to the Text section. Here, you can choose the font, style (like making 

the number bold), size, and color to make the labels clear.  

4. Add a Background for Readability: Go to the Background section. Check the Draw 

Background box. Select a Shape type (Rectangle is a common choice), for this exercise select 

SVG symbol. You can then adjust the Size of the shape and set a Fill Color (e.g., white) to create 

a solid background behind your text  

5. Optimize Placement for Roads: Go to the Placement section. For line layers like roads, you have 

several options  

o Parallel: Places the label straight and aligned with the angle of the road. 

o Curved: Makes the label curve along the path of the road. 

o You can also set the position to Above line, On line, or Below line. 

6. Apply and Adjust: Click Apply or OK to see the changes on your map. You might need to go 

back and fine-tune the font size, background size, or placement distance to get the best results, 

especially if some labels are overlapping or hard to read.  

At this stage, you will see something like the figure below: 

 
 

Another useful tutorials: 

Read more about labelling here  

Another useful tutorial of labelling  

In the next exercise we will construct a symbol that looks like the figure below: 

 
This symbol can identify a roads with its number. 

1. Open the Layer Styling Panel: Select your point layer and go to the Symbology tab in its 

Properties. 

2. Create the Shield Background: 

• Add a Simple Marker symbol layer. 

• Change its Symbol layer type to SVG Marker. 

https://docs.qgis.org/3.10/en/docs/user_manual/style_library/label_settings.html
https://docs.qgis.org/latest/en/docs/training_manual/vector_classification/label_tool.html


• Search for or import an SVG file that looks like a simple road shield (a common shape 

in SVG libraries). 

• Set the Fill color of the shield to white. 

• Set the Stroke color to red (or to transparent/white if you don't want an outline). 

• Adjust the Size of the SVG marker to be large enough to fit the number "7" inside it 

(e.g., 8 mm). 

3. Add the Red Number "7": 

• Click the Add Symbol Layer button (+). 

• Change the new layer's Symbol layer type to Font Marker. 

• Font: Select Arial Black. 

• Character(s): Enter 7. 

• Size: Set to 4.0 mm. 

• Color: Set to red. 

• Use the Offset X and Y values to center the number perfectly inside the shield shape 

you created in the previous step. 

4. Adjust and Save: Ensure the Font Marker layer is above the SVG Marker layer. Use the preview 

to check the alignment, then click OK. You can save this as a custom symbol for future use. 

 
 

Labels of contour lines 
For this exercise, we are going contour line layer uploaded in the File page of this course Canvas 

(Contour Humidity.gpkg). 

To do this follow the following steps: 

1. Open Layer Styling: Select your contour layer in the Layers panel. Go to Properties → Labels 

2. Switch to Single Labels: In the Layer Styling panel, click the drop-down menu that says No 

labels and change it to Single labels. 

3. Choose the Value Field: For the Value option, select the attribute field that contains the value, 

for this exercise use "Contour" field for values. 

4. Consider Label Placement as discussed in the previous sub-chapter, use „on line” placement. 

Add a white-coloured thin buffer  to the text.  

  

Consider Label Placement as discussed in the previous sub-chapter, use „on line” placement. Add a 

white-colored thin buffer  to the text.  



 
 

Labeling names of street in city maps 
Labeling street names effectively in a city map using QGIS involves several steps to ensure the text is 

clear, readable, and well-placed. The core process is to enable labels for your roads layer and then refine 

their appearance and positioning. 

In this exercise we will use Hungarian street names (ut) layer from mo.gpkg . 

1. First change symbology by using the previous discussed method in Line symbology sub chapter. 

This layer has to be visualized as a double line map element. 

2. Then, a label for street name has to be placed "inline", with inline placement method. 

To this follow the following procedures: 

Add Street_roads layer in QGIS from street_road.gpkg 

1. Enable Labeling: Select your roads layer in the Layers Panel. Go to Properties→Labels-Single 

label 

2. Select the Value Field: In the Value dropdown, choose the attribute field that contains the street 

names you want to display. 

3. Format the Text: Navigate to the Text section. Here, you can choose the font, style, size, and 

color to make the labels clear 

4. Optimize Placement for Roads: Go to the Placement section. For line layers, you have several 

option. 

• Parallel: Places the label straight and aligned with the angle of the road. 

• Curved: Makes the label curve along the path of the road. This looks natural but may be harder 

to read on very twisty roads and might result in fewer labels being shown  

• Set the placement position to On line 



 
 

Labels for polygon layer: Around centroid/horizontal (county/settlement name): 
Labeling polygon layers like counties or settlements in QGIS offers several placement options to best 

fit your map's style. The main methods are centered on the feature's centroid or placed freely within the 

polygon boundary. 

For this exercise open county (megye) layer from mo.gpkg later, this is Hungarian counties layer, with 

field containing counties names. 

Add county layer in QGIS, 

1. Enable Labeling: Select your polygon layer in the Layers panel. Go to Properties → Labels → 

Single Label. 

2. Choose Label Field: Switch from No Labels to Single Labels. In the Value dropdown, select the 

attribute field containing the names you want to display ("Nev") 

3. Set Placement: Navigate to the Placement tab. Here, you will find the options listed in the table 

above. Select the one that best suits your needs. 

For Placement position set "Centroid" and Later "Horizontal". 

 



 

Polygon Label Placement Summary 

Around Centroid / Horizontal 

• Best for: County/settlement names 

• Placement: Labels are placed at or near the geometric center 

• Orientation: Strictly horizontal for maximum readability 

• Use case: Administrative boundaries, urban areas where consistent, professional appearance is 

key 

Free (Angled) 

• Best for: Geographic names (mountains, forests, water bodies) 

• Placement: Flexible positioning within the polygon 

• Orientation: Follows natural features or optimal reading angle 

• Use case: Large natural features where label should adapt to the shape 

Using Perimeter: Parallel/Curved 

• Best for: County names at larger scales 

• Placement: Along polygon boundaries 

• Orientation: Parallel to boundary lines or curved to follow contours 

• Use case: When polygons are too small for interior labels or for emphasizing boundary 

relationships 

Rule-based Symbology 

To create your settlement categorization in QGIS, you can use the Rule-based classification feature, 

which is perfect for applying multiple criteria like status and population. Read more about QGIS website 

The process involves defining a separate rule for each of your categories. 

For this exercise, we will use the Hungarian settlement layer (mo-telepules). This layer contains several 

fields, including "jogallas", which means legal status, and "nepesseg_2018", which means population in 

2018. 

Step-by-Step Guide in QGIS 

Follow these steps to implement the rule-based symbology: 

1. Open Layer Properties: Right-click on your settlements layer in the Layers Panel and 

select Properties 

2. Switch to Rule-based Symbology: Go to the Symbology tab. Click on the dropdown menu that 

says "Single Symbol" and change it to Rule-based 

3. Create Your Rules: Click the Add rule button. A new dialog will open where you can define 

each category: 

o Label: Enter a descriptive name for the category (e.g., "jogallas" = 'Megyeszékhely"). 
o Filter: Click the „Epsilon” button next to the Filter field to open the Expression String 

Builder. Here, you will build expressions like: 

o "jogallas" =  'megyeszékhely, megyei jogú város'→ Capital city of the county (1) 

o "jogallas" in ('város', 'megyei jogú város') AND "nepesseg_2018" > 10000 → Big city 

(2) 

o "jogallas" = 'város' AND "nepesseg_2018" <= 10000 → Small city (3) 

o "jogallas" = 'nagyközség'  → Large municipality (4) 

o "jogallas" = 'község' AND "nepesseg_2018" > 2500 → Small municipality (5) 

o "jogallas" = 'község' AND "nepesseg_2018" <= 2500 → Small village (6) 

o Symbol: Double-click on the symbol preview to choose a color, shape, or size for that 

category. 

o Click OK to add the rule 

For Expression String Builder, at this stage, you will see something like the figure below: 

https://docs.qgis.org/3.44/en/docs/training_manual/vector_classification/classification.html#follow-along-rule-based-classification


 
• Repeat for All Categories: Continue adding rules for all six categories in your list. You can 

change the order of rules by dragging them if needed. 

• Apply and OK: Once all rules are defined, click Apply to see the changes on your map. If you 

are satisfied, click OK to close the Layer Properties dialog. 

At this stage, you will see something like the figure below: 

 



 
If you are ready with the categorization, add scale dependent visibility: to categories 4–6. 

4: 1:1,000-1:500,000 

5: 1:1,000- 1:300,000 

6. 1:1,000-1:250,000 

  

How to Set Scale-Dependent Visibility 

After creating your rules as previously discussed, you can define the scale range for each rule. 

1. Open Layer Properties: Right-click on your settlements layer and go to Properties. 

2. Go to Symbology Tab: Ensure that you are in the Symbology tab and your rule-based 

classification is set up. 

3. Edit Each Rule: 

o Double-click on the symbol next to the rule you want to edit (e.g., rule 4 for "Town"). 

o In the Symbol selector window that opens, look for the Scale section, usually near the 

bottom. 

o Here, you will find options to set the Minimum scale and Maximum scale. 

o Enter the values you specified. Remember, a larger denominator means a smaller scale 

(more zoomed out). The table below summarizes your requirements. 

 At this stage, you will see something like the figure below: 



 
Specific Benefits for Scale-Dependent Visibility in Settlement Maps  

1. Prevents Symbol Overlap: At small scales, if you showed all settlements, symbols would 

overlap and become meaningless. 

2. Maintains Hierarchical Importance: Your most important settlements (county capitals, large 

cities) remain visible at all scales, maintaining the map's hierarchy. 

3. Improves User Experience: Readers aren't overwhelmed with information irrelevant to their 

current view. A regional planner zoomed out sees the big picture; a local official zoomed in sees 

community-level detail. 

4. Professional Cartographic Standard: This is how all professional maps are made—showing the 

right information at the right scale. 

Rule-based labeling 

Why Rule-Based Labelling Matters? 

1. Maps Should Tell a Story 

• Without hierarchy, a map reader can not quickly distinguish between a county capital and a 

small village 

• Rule-based labeling instantly communicates "this settlement is more important than that one." 

2. Prevents Label Clutter 

• If all labels were the same size, important settlements would get lost in a sea of text 

• Larger labels naturally stand out, guiding the reader's eye to key locations first 

3. Professional Cartographic Standard 

• All professional maps use hierarchical labeling: 

o Highway maps: Interstate labels → US highways → state roads 

o Topographic maps: Major cities → towns → villages 

o Your map: County capitals → cities → towns → municipalities 

4. Matches Your Symbology Hierarchy 

Your labeling hierarchy should mirror your symbol hierarchy: 

• Big symbols (county capitals) → Big labels 

• Medium symbols (cities) → Medium labels 

• Small symbols (towns/municipalities)→ Small labels 

  

To add the rule-based labeling to the rule-based symbology, follow the following procedures: 



1. Access the Labeling Settings 

• Right-click your settlements layer → Properties → Labels tab 

• Change the dropdown from "No labels" to "Rule-based labeling" 

2. Create Labeling Rules 

Click "Add rule" for each category: 

Rule 1: Megyeszékhely (County Capitals) 

• Filter: "jogallas" =  'megyeszékhely, megyei jogú város' 

• Description: "County Capitals" 

• Text Formatting: 

• Size: 10 pt 

• Style: Bold 

• Underline: Checked 

• Case: Uppercase 

Rule 2: Cities (város) 

• Filter: "jogallas" in( 'város' , 'megyei jogú város' ) 

• Description: "Cities" 

• Text Formatting: 

o Size: 8 pt 

o Style: Bold 

o Case: Uppercase 

o Underline: Unchecked 

Rule 3: Towns (Nagyközség) 

• Filter: "jogallas" = 'nagyközség' 

• Description: "Towns" 

• Text Formatting: 

o Size: 7 pt 

o Style: Bold 

o Case: No change (keep original case) 

Rule 4: Municipalities (község) 

• Filter: "jogallas" = 'község' 

• Description: "Municipalities" 

• Text Formatting: 

o Size: 6 pt 

o Style: Normal (not bold) 

o Case: No change 

At this stage, you will see something like the following figure: 



 
Your final map should look something like the figure below: 

 

Selections 

This tool selects vector features from the map and/or the attribute table. There are three types of 

selections:  

• Selection with a shape 

• Select with an expression 

• Select by spatial relations 

Selection with a shape 
The selection works on the active layer. Active layer is that layer, which is in focus. Put the focus on 

hungary.gpkg county (megye) layer, and make single click on a feature. If you hold pressed the Shift 

button, you are able to select more features. 



Besides this, there are four shapes in QGIS that users can apply for selection: these are the rectangle  

called Select Feature(s) (the tool is same as the single click selection); Select features by Polygon (user 

defined area); Select features by Freehand (follows the movement of the mouse); and Select Features 

by Radius (uses a circle for selection). 

 

Select with an expression 
This tool helps to select the features according to their attributes. QGIS uses an SQL-like query 

window, which stand from three column: in the first one, you can give the expresssion. In the second 

column, you can find the available tools in groups, and in the third one, you will see the description of 

the tool, if you click on them. After the expression is given, run the the Select Features. 

What are the most important groups? 

• Field and Values contains all fields of the active layer. If you click on the field name, in the 

right column you can load the distinct values. 

• Operators are the standard SQL operators, like mathematical (=, >, <>, etc.) and logical (OR, 

AND, NOT etc.) operators, mathematical operations (addition, substraction etc.), and other 

operators (LIKE, BETWEEN, IN etc.) 

• Math section contains the mathematical functions e.g. tan, sin, sqrt etc. 

• String group contains the string processing functions e.g. strpos,  right, length, substr etc. 

• Geometry group gives access to the features geometry, like area size, length etc. 

Exercise 
Select all settlements from the hungary.gpkg settlement layer (telepulesek), where the name contains 

somewhere the following string: „szent”. (This world means saint in Hungarian). Count how many 

settlement names has this string! 

1. Set the active layer: hungary.gpkg settlement layer (telepulesek) 

2. Open the Select by Expression tool 

3. Type the expression. Alternatively, you ca move the necessary expressions to left column with 

double click: "nev" ILIKE '%szent%' →  

Field name is marked with this "nev" quotation mark.  

ILIKE → Returns TRUE if the first parameter matches case-insensitive the supplied pattern. 

LIKE can be used instead of ILIKE to make the match case-sensitive. Works with numbers 

also. Syntax: string/number ILIKE pattern 

Pattern to find: you can use '%' as a wildcard, '_' as a single char and '\\' to escape these 

special characters. 

4. Select the features. 

5. After the selection, you can read in the bottom left part of the QGIS window, how many 

features were selected. 



 
 

Select by spatial relations 

 
This algorithm creates a selection in a vector layer. The criteria for selecting features is based on the 

spatial relationship between each feature and the features in an additional layer. 

Exercise 
1. Select all settlements in Fejér county (you need to open hungary.gpkg settlement layer 

(telepulesek) and county (megye) layer)! 

• Set county layer as an active layer and select Fejér county by Single click. 

• Open Select By Location → and set the following parameters 

• Select features from SETTLEMENT Layer where the features INTERSECT By 

comparing to the features from COUNTY Layer (Selected features only). Modify 

current selection by creating new selection. 



 
2. Select all neighbouring county of Fejér county! 

• Set county layer as an active layer and select Fejér county by Single click. 

• Open Select By Location → and set the following parameters 

• Select features from COUNTY Layer where the features TOUCH By comparing to the 

features from COUNTY Layer (Selected features only). Modify current selection by 

creating new selection. 

 
 

Deselect features 
You can close the selection on the current active layer or all layers. 

 



Creating the basemap 

In cartography, a basemap is a background reference map on which other thematic layers or 

geographic data are overlaid. It provides context—such as geography, landmarks, and political 

boundaries—allowing viewers to understand the location and relationship of data being presented. 

In this exercise, we will work on preparing a Basemap by following the steps below: 

1. Load the almost the full mo.gpkg (except: orszaghatar, jaras, patak layers).  

2. Create a county map. The map contains the features only in Fejér county. Crop all layers to Fejér 

county. Geoprocessing Clip or Intersection. 

First, you will need to select by attribute layer "Fejér" from mo-megye layer, to do this follow the 

following steps: 

• Open attribute table for mo-megye 

• Highlight the row containing "Fejér" in nev column 

• Minimize the attribute table view and go back to map Canvas, the "Fejér" will be highlighted. 

• Right click mo-megye layer, export the layer 

• Remember to check the box "Save only selected feature" 

• Export this layer to mo.gpkg 

At this stage, you will see something like the figure below: 

 
At this stage, you willl have the "Fejér" layer in your panel layer order. 

Now to Crop all layers to Fejér county use Geoprocessing Clip or Intersection. 

By using Clip tool follow the next steps: 

Open the Clip Tool 

Go to: Processing → Toolbox In the Processing Toolbox, search for: Clip (under Vector overlay) 

Then double-click Clip. 

  

Set Clip Tool Parameters 

In the Clip dialog: 

• Input Layer → select the layer you want to crop (e.g., roads, rivers, land use, etc.) 

• Overlay Layer → select your Fejér boundary layer (fejer_boundary) 

• Output → choose where to save the clipped result (optional) 

Click Run. 

Repeat for Multiple Layers: 

You can repeat the clip operation for each layer you want to crop. 

  



Save all layer new folder, inside a folder as for example for main connecting roads "Fejér-fout", use this 

naming method for easy layer identification. Use geopackage format (.gpkg). 

At this stage, you will see something like the figure below: 

 
This task can also be done by using intersection tool as shown in the figure below:   

 
Both Clip and Intersection are geoprocessing tools that extract the overlapping (intersecting) area 

between two layers — but they behave differently in terms of attributes and geometry. 

 

Clip (Vector Overlay Tool) 

 What it does: 

• Extracts only the geometry (spatial part) of the input layer that overlaps (intersects) with the 

overlay layer. 

• Keeps only the input layer’s attributes. 

• Does not add any attribute data from the overlay layer. 

Intersection (Vector Overlay Tool) 

What it does: 

• It also extracts only the overlapping area between input and overlay layers. 



• BUT: it adds attributes from both layers into the result. 

• Each intersecting feature is created as a new feature, often splitting geometries if needed. 

  

3. Order the layers: from bottom to top: borders, river polygons, river lines, railroad, roads, main roads, 

centroid of settlements. 

At this stage, you will have all layers prepared and presented as the figure below: 

 
 

After preparing your layers, the next stage is to add symbology. 

In applying symbology, we will use the procedures already discussed in the previous symbology chapter. 

Follow the following guideline: 

1. Main connecting roads (Fejér-fout): 

• Double line map element 

• Categorized based on tipus (type) 

• Color from red to orange  

• Width 1mm 

2. Stree roads (Fejér-ut) 

• Color white 

• Width 0.5mm 

3. Fejér-vasut (railways) 

• Use railway symbology 

• Width 0.5 

4. Fejér-folyo-vonal (rivers-line features) 

• Fill color Cyanic blue  

• Stroke color blue 

5. Fejér-folyo (rivers-polygon features) 

• Use double line element 

• Use cyanic blue fill 

6. Fejér-telepules 

• Use categorized symbology by "size". (not by "color") 

• Color deep brown 

• 8 classes 

• Equal interval classification 

7. Fejér-nagy-to (large lakes) 

• Fill color cyanic blue 

• Stroke color blue 



8. Fejér-belterulet (built up areas) 

• Fill color brown 

• Stroke color brown 

10. Fejér-to (lakes) 

• Fill color cyanic blue 

• Stroke color blue 

11. Fejér-folyo-felulet 

• Fill color cyanic blue 

• Fill color blue 

12. Fejér 

• Fill color near to pale color 

• Stroke color black, dashed 

13. Fejér-kulterulet (land outside the built-up area) 

• Fill color near to pale color 

• Stroke color black 

  

At this stage, you will see something like the figure below: 

 
Recap: We discussed labelling in Module 3, thus apply labels as the discussion held in Module 2. 

Hint: 

• Text 

• Formatting 

• Background 

• Label placement 

• Label background (draw background for main connecting roads, label by road number) 

Adding the thematic dataset 

In this exercise, we will add Excel datasets (ksh-census2022-fejer) in QGIS and join them with the 

(Fejér-kulterulet) layer. 

First download (ksh-census2022-fejer) and save it as a CSV Comma-delimited file format. 

To do this, follow the following steps: 

1. Open the Data Source Manager: Click on the Layer menu, select Add Layer, and then 

choose Add Delimited Text Layer. Alternatively, you can click the „Open Data Source 



Manager” button on the toolbar and select the „Delimited Text” tab. Another nice example 

avialable here 

2. Select and Configure Your File: 

• Click the Browse button next to the "File Name" field and locate your ksh-census2022-

feje CSV file 

• For Geometry Definition, select the radio button for No Geometry (attribute only table). 

This is the most important step for your request. 

• Ensure the File Format is set to CSV and the chosen Encoding (Windows-

1250) correctly displays any special characters in your data. 

• Import the Layer: Once the settings are configured, click Add. The table will be loaded 

into your QGIS project and appear in the Layers Panel. You can open its attribute table 

to view and work with the census data. 

At this stage, you will open the attribute table to see the content, you will see something like the figures 

below: 

 
 

 
Now, join this table to Fejér-kulterulet.  

To do this, follow these steps: 

https://guides.library.duke.edu/QGIS/ImportData
https://guides.library.duke.edu/QGIS/ImportData


Before starting, ensure both your CSV layer and Fejér-kulterulet are loaded in QGIS and that they share 

a common identifier column (nev-settlement name). 

  

1. Open Layer Properties Double-click your "Fejér-kulterulet" layer in the Layers Panel to open 

its Properties. 

2. Go to the Joins Tab In the left-hand menu, click on the Joins tab. 

3. Create a New Join Click with the green + (plus) button at the bottom to open the Add Vector 

Join dialog box. 

4. Configure the Join Settings, Join layer: Select your imported KSH Census CSV table. Join field: 

Choose the common column (nev-settlement). 

5. Finalize the Join Click OK in the Add Vector Join window, then click OK again in the Layer 

Properties window to apply the join. 

At this stage, you will see something like the figure below: 

 
Now, the settlement layer will have all the attributes from CSV Census table, In our next exercise, we 

will create a diagram map from this column (pie chart). 

Pie chart map 

In this exercise, you will create a diagram map by utilizing the Basemap you created in the previous 

sub-chapter. 

Create a pie chart map.  

The number of slices in the pie chart can be 4 or 5. Possible age groups:  

• children 0-19 

• young adults 20-39 

• adults 40-65 

• retired 65+ 

  

To do this follow the following steps: 

  

Creating a pie chart map in QGIS is done through the "Diagrams" tab in your layer's Properties. This 

feature lets you display attribute data as proportional pie charts directly on your map. 

1. Enable Pie Charts: Select "Pie Chart" from the drop-down menu and ensure the "Display 

diagrams" box is checked. 



2. Add Your Slices (Attributes): In the Attributes list, select each numeric field you want to 

become a slice of the pie and click the plus + button to add it. 

3. Customize the Slices: 

• Colors: Double-click the color box next to any attribute to change its slice color. 

• Size: You can set the pie chart to a Fixed size or have it Scaled based on the value of 

another attribute, for example the total population of a settlement. 

At this stage, you will see something like the figure below: 

 
 

The Layout – Paper (PDF) map 

In QGIS, the Print Layout is where you assemble all the elements of your map for printing or digital 

publication. It's a dedicated workspace that lets you arrange components like the main map, legend, and 

scale bar on a page, separate from the main map canvas where you style your data. 

The Central Element: The Map Item 
The most crucial element is the Map Item itself. This is a window that displays the map you have created 

in the main QGIS canvas. You can adjust its size and position on the page, and fine-tune the view by 

setting a specific scale or rotating the map to a desired orientation. For more complex layouts, you can 

add multiple map items to create insets—smaller maps that show a zoomed-in view of a particular area 

or a broader geographical context. 

Essential Cartographic Elements 
To make your map readable and professional, you should include several standard elements: 

• Legend: A legend explains the symbols, colors, and line styles used to represent the different 

layers on your map. You can customize it by renaming layer labels, changing the order of items, 

and controlling which layers are displayed. 

• Scale Bar: A scale bar provides a visual representation of distance on the map. You can choose 

from different styles and configure the units (like meters or kilometers) and the number of 

segments to suit your map's design. 

• Scale text 

• North Arrow: A north arrow indicates the map's orientation. QGIS comes with a collection of 

SVG images that you can use as north arrows, and you can adjust their size and position on the 

layout. If your map is North oriented North Arrow becomes unnecessary. 



• Labels and Titles: You use text labels to add a title, your name as the cartographer, data 

sources, the date of creation, or any other descriptive information. The appearance of all text 

can be customized for font, size, color, and alignment. 

• Grids and Graticules: You can add a grid or graticule (showing lines of latitude and longitude) 

to your map to help readers reference specific locations. You can control the interval between 

grid lines and choose how to display the coordinates. 

  

Additional Decorative Elements 
Beyond the core components, you can enhance your layout with other items: 

• Shapes and Images: You can add basic shapes like rectangles or arrows to highlight areas or 

draw attention. It's also common to add images, such as a logo for your organization. 

• Map Frames: Adding a frame around your map or other elements can help define the 

composition and make the layout more visually cohesive. 

  

Finalizing and Exporting Your Layout 
Once your layout is complete, you can export it to various formats. Exporting as a PDF is common for 

sharing and printing, while exporting as an image (like PNG) creates a standard picture file. For 

advanced editing in vector graphics software like Adobe Illustrator or Inkscape, you can export as 

an SVG file. 

  

How to Create a Basic Map Layout in QGIS 
In this exercise, we will use the already made diagram map from the previous chapter, to create a map 

layout from it, finalize and export the final map. 

Open QGIS and your diagram map. 

1. Open the Print Layout: Go to Project → New Print Layout and give it a name 

2. Set Up the Page: Right-click on the blank page and select Page properties. Here, you can set the 

paper size (e.g., A4) and orientation (Landscape). For this exercise set a paper size to A4 and 

Landscape orientation to landscape so as to have enough space to place the map and its legend. 

At this stage, you will see something like the figure below: 

 
3. Add a Map: Click Add Map, then click and drag on the page to draw a rectangle where your 

map will appear. 

You will see something like the figure below: 



 
4. Add Other Elements: Use the dedicated buttons to add a legend, scale bar, north arrow, and title. Each 

element can be moved and resized after placement. 

Adding a Map Title 
Add a Label: Click on the Add Label button in the toolbar or go to the Add Item menu and select Add 

Label. 

Place your map title in top left corner. At this stage, you will see something like the figure below: 

Customize the label appearance by adjusting, Font type, Font size, and font style (bold, italic, underline, 

etc.). You can also align the title inside its frame (vertical and horizontal alignments are also available). 

This frame can have a border and background as well. 

 
In the Main Properties section, you will see a text box. Replace the default text (like „Lorem Ipsum” 

or „QGIS”) with your actual map title, for example, „Distribution of age in Fejér County”. 

To add a scale text follow the procedures in the figure below: 



 
In the scale, customize it to be (1:500,000), note this depends on your map scale. 

 

Adding a Scale Bar to Your Layout 
To add a scale bar, follow the guide in the figure below: 

Scale bars have several styles, like single box, double box, some types of line ticks, stepped lines and 

hollows. Its size and segments can be defined in the Units and the Segment’s section. In case of small 

scale maps, use km-s for units. The number of segments is usually 2-4. Fixed width of segments means 

how many units one segment is. Right segments are the normal segments, the number shows, how many 

normal segments are drawn, left and the number means the number of subsegments in the first part of 

the segments. 

If the scale is a pretty number like 1:500,000 or 1:100,000 etc. it is recommended to add the scale as a 

numeric scale, below the scale bar. 

 
Use the Dynamic Text Menu: For quicker access, click the Dynamic Text button next to the 

expression button. This menu provides a list of common dynamic text options, such as Project Author, 

that you can insert with a single click. 

To do this, follow the guide in the figure below: 



 
To add CRS information to the Layout, follow the guide in the figure below: 

 

Add Grid (EOV grid) and coordinates: 
Setting up the EOV Grid 

Access Grid Properties: In the Layout, select your map item. Find the Item Properties panel and scroll 

down to the Grids section. Click the Add a new grid button. 

At this stage, you will see something like the figure below: 



 
• Enable the Grid: In the Map Grid Properties panel that appears, ensure Grid enabled is checked  

• Set Grid CRS: Click the Change button next to CRS. In the CRS Selector window, search 

for 23700 (the EPSG code for HD72/EOV). Select it from the list and click OK 

• Choose Interval Type and Units: Set the Interval to Map units. Since EOV uses meters enter 

your desired grid spacing (e.g., 10000 for a 10 km grid) for both the X and Y direction. 

• Select Grid Style: Under Grid type, you can choose: 

o Solid: draws continuous lines. 

o Cross: draws segments at line intersections. 

o Marker: places a symbol at intersections 

• Lastly enable "draw" grid coordinates by following the guide in the figure below: 

 

Map Legend 
Finally add a legend and categorize legend elements as follows: 

Group all road network together by deactivating "auto-update legend", and start to customize the legend 

by grouping items. 

  

First add the legend by following the guide in the figure below: 



 
Un check the "auto-update legend", to customize the legend and add road networks into one group, name 

it (Road networks). 

Personal note: I know that nobody really likes creating the legend and everyone tends to see it as a 

necessary evil.  :) Unfortunately, no matter how good a map is, if the legend is not prepared well with 

sufficient care, it is of little value. 

Important aspects of creating the legend: 

One of the most important points about the legend is that it should be created in the language of the 

intended audience (Now, it is English...). In other words, instead of using Hungarian layer names, 

everything should be translated into English. 

Do not use the default layer names! In most cases, these are temporary names. The map legend 

should be grammatically correct. Every item in the legend begins with Capital letter. The legend 

should be easy to read and not overcrowded. Use simple, legible fonts (e.g., Arial, Calibri). The 

font size and symbol size should match the overall map scale. Omit items that don’t need 

explanation or are duplicated. 

The map legend always has a title 'Legend' or 'Map key'.  

In the case of thematic maps, explain the thematic content first. In our case, this is the slices of diagram. 

Age group in population (years): 

younger  than 10 (or alternatively <10) 

10-19 

20-29 

30-39 

40-49 

50-59 

60 and older (or alternatively 60+) 

Then, you can explain the feature types of the basemap. In the case of road, you can order the items 

according to their hierarchy. The most important is the first. 

Road network: 

Motorway 

Primary roads 

Secondary roads 

Other roads 

Railroads 

  

Do not display the red dots of the settlements. Omit the other elements from the legend. 

  

The final touches of your layout will look like the figure below: 



 
To export as a PDF: 

1. Click the Export as PDF button (it looks like a PDF icon). 

2. Choose a save location and filename 

3. In the PDF Export Options dialog, you can adjust settings. 

  

To export as a PNG: 

1. Click the Export as image icon and select PNG as the format. 

2. Choose a save location and filename. For multi-page layouts, each page will be saved with a 

page number appended  

3. In the Image Export Options dialog, you can: 

• Increase the Export resolution (DPI) for a higher quality, sharper image. 

• Check Generate world file to create a companion file that georeferences the PNG. 

• Check Crop to content to automatically resize the image to fit all your map elements 

neatly. 

• Click Save to export. 

Note that the Legend will only contain important elements that needs a Legend for their visualization, 

the Legend will now contain: 

1. Road networks 

2. Railways 

3. Pie chart diagram categories 

  

Customize your Legend in the Layout stage to omit un-necessary elements, those elements they should 

remain in the map only. 

  

Your final Layout should like the figure below: 



 
 

 



Web map 

Creating a web map in QGIS typically involves designing your map in the desktop application and then 

using a dedicated plugin like QGIS2Web to export it as a set of interactive web files. For more advanced 

needs, you can also use QGIS Server to publish maps directly as OGC web services. 

qgis2web Plugin 

Exports QGIS project to a folder with HTML, JavaScript, and CSS files for web publishing. No 

programming needed (QGIS2WEB – a nice introduction); supports OpenLayers or Leaflet 

(QGIS2WEB - Tutorial); replicates QGIS symbology; includes pop-ups, search, and measurement. 

Users without coding skills: quick static web maps for sharing via a web server. 

The QGIS2Web plugin is a powerful tool for QGIS that allows you to export your desktop GIS projects 

into interactive web maps without needing server-side software or programming skills. It works by 

generating all the necessary HTML, CSS, and JavaScript files for you to host on a web server. 

  

How to Create a Web Map with qgis2web 

Prepare Your QGIS Project: The appearance and behavior of your web map are directly based on your 

QGIS project. For this Exercise we will use a diagram of (Fejer county). 

Follow the following guide to create a web map in QGIS: 

1. Style your layers using categorized or graduated symbology.  

2. Configure pop-ups by setting irrelevant field widgets to "Hidden" in the Layer Properties → 

Attributes Form. You can also set fields to display as photos or hyperlinks.  

3. Add a basemap by using Data Source Manager → XYZ tiles → OSM 

4. Save your QGIS project 

  

Export with the qgis2web Plugin: Install the plugin via Plugins → Manage and Install Plugins 

 

https://gisgeography.com/qgis2web/
https://www.qgistutorials.com/en/docs/3/web_mapping_with_qgis2web.html


 
1. In the export dialog, you can configure layers, pop-up fields, and choose between Leaflet (often 

recommended for its balance of features and accurate style replication) or OpenLayers.  

2. Under the Appearance tab, add useful tools like a layer list, address search, and measurement 

tools. 

3. Preview your map and click Export to generate a folder containing all the web files. 

At this stage, you will see something like the figure below: 

 



 
 

 
In the files folder where you exported your WebMap, you can open an „index.html” and customize it 

according to your styles. 

  

For Example we are going to add a title "Fejér county WebMap" and Heading „Fejer county WebMap”. 

Your code should look like this: 

 

Notes: not every types of Symbology is available to export: for example, Rule-based Symbology and 

Rule-based labeling can not be correctly exported into a Webmap. You should rather use Single, 

Graduated, or Categorized Symbology for layers. Diagrams, like pie chart are also not available for 

export. 



 

Geoprocessing tools - theory 

 Core Concept of Geoprocessing 
Geoprocessing is like a toolkit for your geographic data. It takes one or more input spatial datasets 

(layers), performs a defined operation, and creates a new output dataset. This is how you answer spatial 

questions and prepare data for analysis. 

1. Buffer 
A Buffer tool creates a polygon zone around input features. The input features can be points, lines, or 

other polygons. You define the buffer's size, which can be a fixed distance or a variable based on an 

attribute in the layer's table. 

• Purpose: To answer "proximity" questions. For example, "Which land parcels are within 500 

meters of a river?" or "Create a protected zone around eagle nests." 

• Input: Points, Lines, or Polygons. 

• Output: A Polygon layer. 

 
Source of figure: https://pro.arcgis.com/en/pro-app/latest/tool-reference/analysis/buffer.htm 

2. Dissolve 
Dissolve merges neighboring polygons that share a common attribute value into a single, larger polygon. 

It effectively removes the boundaries between them. 

• Purpose: To simplify data and create larger regional units. For example, you might have a map 

of US counties, and you want to create a map of states. You would dissolve the counties based 

on their "State_Name" attribute. 

• Input: Polygons (primarily) (on the left). 

• Output: Polygons (on he right). 



  
 
 

3. Convex Hull 
A Convex Hull is the smallest convex polygon that can encompass all features in a layer or a group of 

features. A convex polygon has no indentations; if you were to stretch a rubber band around all the 

points, the shape it forms is the convex hull. 

• Purpose: To determine the "span" or "minimum bounding area" of a set of features. For 

example, "What is the total range of wolf pack sightings?" or "Find the general area covered by 

a set of weather stations." 

• Input: Points, Lines, Polygons (it will create a hull around their outer extremities). 

• Output: A Polygon. 

 
 

4. Union 
The Union tool combines the geometry and attributes of two polygon layers. The output contains all 

areas from both input layers. Where the polygons overlap, new polygons are created that contain 

attributes from both original layers. 

• Purpose: To create a comprehensive layer that merges two datasets. For example, combining a 

land use map with a soil map to see all possible combinations of land use and soil type. 

• Input: Two Polygon layers. 

• Output: A single Polygon layer. 

         

5. Intersection (and Clip) 
Intersection is a more specific tool than Union. It only keeps the areas where the two layers overlap. 

The output features contain the attributes from both input layers, but only for the overlapping areas. 

Clip is a special, very common case of Intersection. You use Clip when you have a "cookie-cutter" 

polygon (like a county boundary) and you want to cut another layer (like roads) to fit inside it. The 

output only has the attributes of the "clipped" layer, not the "cookie-cutter". 

• Purpose (Intersection): To find the common area between two layers and combine their 

attributes. (e.g., "Find all wetlands located on public land"). 

• Purpose (Clip): To extract a piece of one layer using the boundary of another. (e.g., "Get all 

the roads that fall within a specific national park"). 

• Input: Any two layers (Points, Lines, or Polygons). (On the left) 

• Output: The same geometry as the first input layer, but only where it overlaps the second (On 

the right) 



                 
 

6. Difference (Erase) 
The Difference tool (often called Erase) subtracts the area of the second layer from the first layer. The 

output contains only the parts of the first input layer that do not overlap with the second layer. 

• Purpose: To remove features from one layer based on the geometry of another. (e.g., "Find all 

available land for development by erasing protected areas from a total land parcel layer"). 

• Input: Any two layers. 

• Output: The same geometry as the first input layer. 

            
Difference of the Brown – Purple layers 

 

                     
Difference of the Purple – Brown layers 

 

7. Symmetrical Difference 
Symmetrical Difference is the opposite of Intersection. It keeps the areas that are in either of the two 

layers, but not in both. It's the geometric equivalent of the logical "XOR" (exclusive OR). 

• Purpose: To find areas that are unique to each input layer, excluding their common area. (e.g., 

"Find all land that has changed between 2010 and 2020, ignoring areas that remained the same"). 

• Input: Two polygon layers (On the left). 

• Output: A single polygon layer (On the right). 

       
 



8. Centroid 
The Centroid tool calculates the geometric center (or center of mass) of a feature and creates a point at 

that location. For polygons, this is the center point of the shape's area. For lines, it's the midpoint along 

the line's length. 

• Purpose: To represent area or line features as points for analysis, labeling, or symbology. For 

example, "Calculate the average distance between cities by using county centroids" or "Place a 

label at the center of each park polygon." 

• Input: Polygons or Lines. 

• Output: Points. 

 

9. Multipart to Singlepart 
The Multipart to Singlepart tool breaks apart "multipart" features into individual "singlepart" features. 

A multipart feature is one where a single record in the attribute table is made up of multiple, disconnected 

geometries. 

• Purpose: To separate complex features into their component parts for analysis, mapping, or 

data management. For example, "The Philippines is stored as one multipart polygon feature (one 

record for the entire country). You need each individual island to be its own polygon for 

analysis." 

• Input: Any geometry type (Points, Lines, Polygons). 

• Output: The same geometry type, but with each physical part as a separate feature. 

  

 
Scenario: You have a layer of "U.S. States," but Hawaii is stored as a single multipart feature. 

• Input Layer (Multipart): 

o The attribute table has one record for "Hawaii." 

o On the map, this one record draws all eight major Hawaiian Islands. 

• Multipart to Singlepart Process: 

o The tool identifies each disconnected physical part of the "Hawaii" feature. 



o It creates a new, separate feature (with its own new row in the attribute table) for each 

island. 

• Output Layer (Singlepart): 

o The attribute table now has eight records, all with the attribute "State_Name = Hawaii". 

o On the map, each island is now a selectable feature independently. You could now 

calculate the area of each individual island. 

  

Geoprocessing tools – practice 

  

Note: All layers should be saved in the geopackage. 

Our aim is to define possible places for a poultry plant in Fejér county. With the available geoprocessing 

tools, please find possible places for the plant. Finally, show the possible areas on the map using diagonal 

hatching! 

• The plant cannot be located within a 4 km radius of Lake Velence or the Danube River, as 

chicken manure poses a risk to natural waters. 

• Since chickens produce unpleasant odors, the site must be at least 2 km away from residential 

areas. 

• Furthermore, for transportation reasons, to prevent the many eggs from breaking on bumpy side 

roads, the facility should be located no more than 1 km from main roads. 

• The site must cover at least 10 hectares, as a smaller area would not be sufficient to 

accommodate the  plant. 

   

Data and criteria for a Suitable site 
1. Fejér county Road networks (Less than 1 km from road networks). 

2. Fejér county Built-up areas (More than 2km from built-up areas). 

3. Fejér county Lakes (More than 4km away from Lake). 

4. Fejér county Rivers (More than 4km from River). 

  

 In this exercise we will use Geoprocessing tools we discussed in the previous sub-module. 

1. Starting with Built-up areas network criteria. 
Add Fejér county built-up areas. At this stage, you will see something like the figure below: 

 
Now Use Menu Vector → Geoprocessing → Buffer 



Buffer this layer by 2 km (2000 m) and save it as „builtup_buffer”. Allow Dissolve option during buffer. 

You will see something like the figure below: 

 

 
The result layer: 



 
Now, we repeat the same procedure for Lake, buffer Lake by 4 km (4000 m) Save it as „lake-buffer”. 

At this stage, you will have a result looking like the figure below: 

 
Now, we will repeat the same procedures for River layer, buffer it by 4 km (4000 m), Save it as 

„river_buffer”. At this stage, you will see something like the figure below: 



 
At this stage, note that suitable sites are those sites that are within Fejér County boundary, but outside 

of these layers (builtup_buffer, river_buffer, lake_buffer). Thus, use Symmetrical Difference tool for 

Fejer County and builtup_buffer, repeat for lake_buffer and river_buffer layers. 

Save each output as Symmetrical difference 2, Symmetrical difference 3, and Symmetrical difference 

4. 

Follow the guide in the figure below: 

 
 



 
Now, find the common areas between these suitable sites. Use intersection tool for layers Symmetrical 

difference 2 and Symmetrical difference 3, and the resulted output with Symmetrical difference 4. Save 

the results as Suitable site 1. Follow the guides in the figure below: 

 
 



 
Now we have only the Suitable site based on three layers, we have to add road network, Buffer it for 1 

km (1000 m). 

At this stage, you will see something like the figure below: 

 
 



 

 
Now use intersection tool as discussed earlier to Find an area of intersection between Suitability site 1 

and Buffered road network. 

At this stage, you will see something like the figure below: 



 
Now our final criterion is: 

• The site must cover at least 10 hectares, as a smaller area would not be sufficient to 

accommodate the  plant. 

First, use Multipart to Single part tool to break the Suitable site into independent layers. To do this 

follow the guide in the figures below: 

 
 



 
Now Open Attribute Table → Calculate Field then Calculate Geometry by Creating a new Area field, 

divide the expression by 10,000 to convert from square meters to hectares. 

At this stage, you will see something like the figure below: 

 
 



 

 
 Now use Select feature by Expression, for Area >=10 (Hectares), use the guide in the figure below: 



 
Save the selected features as a new layer in Hungarian EOV projection. This layer is the result of the 

geoprocessing. 

 
 



 
Set hatching for the result layer in Layer Properties → Symbology. Use Line pattern fill as fill style. 



Your final output should look like the figure below:

 
 

 



Projections in QGIS  

What is a Map Projection 

A map projection is a systematic method for representing the three-dimensional, curved surface of the 

Earth (or another celestial body) onto a two-dimensional, flat surface, such as a piece of paper or a 

computer screen. 

Because it is mathematically impossible to flatten a sphere without distortion, every map projection 

distorts the Earth's surface in some way. 

The Core Challenge: The Distortion Problem 

The fundamental problem of cartography is that a sphere (or spheroid) is not developable. You cannot 

flatten the peel of an orange without it stretching, tearing, or compressing. Similarly, map projections 

must distort at least two of these four key properties: 

1. Shape (Angles): Preserving local angles and shapes. 

2. Area (Size): Preserving the correct relative sizes of areas. 

3. Distance: Preserving accurate distances from one or more points. 

4. Direction: Preserving accurate directions (bearings) from one point to another. 

  

Classification of Map Projections 

Map projections are typically classified in two primary ways: by the shape of the graticule images, and 

by the properties they preserve. 

1. By Shape of Graticule 
• Cylindrical: Latitude and longitude lines are all straight lines intersecting each other at right 

angles. 

o Distortion: Increases away from the standard parallels (e.g., the Equator). Polar areas 

are severely distorted. 

o Example: Mercator Projection. 

• Conic: Parallels are mapped to concentric arcs of circles, meridians to concurrent straight lines 

perpendicular to parallels. 

o Distortion: Increases north and south of the standard parallel(s). Best for mid-latitude 

regions. 

o Example: Albers Equal-Area Conic (used for the conterminous USA). 

• Azimuthal: Parallels are concentric circles; meridians are straight lines radiating from the 

center of these circles. 

o Distortion: Increases radially from the point of tangency. Excellent for showing 

hemispheres or polar regions. 

o Example: Orthographic Projection (like a view from space), Gnomonic 

Projection (used for great-circle navigation). 

• There are a lot of other classes like pseudocylindrical, polyconic, etc., but these are rarely used 

for regional mapping. 

2. By Preserved Property (Distortion Characteristic) 
• Conformal (Angle-Preserving): Preserves local angles and shapes. Infinitely small features 

appear with their correct shape.  

o Trade-off: Distorts areas significantly, especially at small scales. 

o Use: Navigation, topographic mapping, weather maps. 

o Example: Mercator Projection. 

• Equal-Area (Equivalent): Preserves the relative sizes of all areas. A 1 sq. km area on the globe 

is shown as 1 sq. km on the map, everywhere. 

o Trade-off: Distorts shape, scale, and angle. 

o Use: Thematic maps showing density or distribution (e.g., population density, land 

use). 

o Example: Eckert IV. Projection, Albers Equal-Area Conic. 

• Equidistant: Preserves accurate distances from one or two points to all other points. No 

projection can preserve all distances. 



o Use: Radio or seismic mapping where distance from a central point is critical. 

o Example: Azimuthal Equidistant Projection (used for the UN logo). 

• Compromise (Neither Conformal nor Equal-Area): Attempts to minimize overall distortion 

by striking a balance between shape and area. No property is perfectly preserved, but the map 

"looks right" for world views. 

o Use: General-purpose world maps. 

o Example: Robinson Projection, Winkel Tripel Projection (used by National 

Geographic). 

Key Takeaways 
• No Perfect Map: There is no single "best" map projection. The choice is always a trade-off. 

• Purpose Dictates Choice: The map's intended purpose determines which projection is most 

appropriate. A navigator needs a conformal map, while a demographer needs an equal-area map. 

• Scale Matters: Distortion is often minimal for large-scale maps (e.g., of a city) but becomes a 

critical issue for small-scale maps (e.g., of the world). 

• Awareness is Key: Understanding the distortions inherent in a projection is essential for 

correctly interpreting any map. 

 

For further reading in this topic: Kerkovits Krisztián: Lecture Notes in Map projections 

  

How CRS Works in QGIS: The Three Key Levels 
QGIS manages CRS at three distinct levels, which is crucial to understand. 

1. Project CRS 
This is the common "drawing canvas" for your map. When you add layers with different native CRS, 

QGIS will (by default) reproject them on-the-fly to match the Project CRS so they all line up correctly. 

• How to Set It: 

o In the bottom-right corner of the QGIS window, you'll see a button 

like EPSG: 4326 or Unknown CRS. Click it to open the Project Properties CRS tab. 

o You can also go to Project →  Properties → CRS. 

o Search for or filter by a CRS (e.g., "UTM zone 33N") and select it. 

To set this option follow the guide in the figure below: 

 

2. Layer CRS 
This is the native CRS of the source data file (the shapefile, GeoPackage, etc.). Each layer has its own 

CRS, which is defined in a small file (like a .prj file for a shapefile). 

• How to See It: The layer's CRS is displayed in the Layer Properties (under the Source tab) and 

in the Layer Styling panel. 

https://mercator.elte.hu/~kerkovits/honlap/diasor/proj.pdf


• The Golden Rule: Never use the "Set Layer CRS" tool (right-click layer → Layer CRS → 

Set Layer CRS...) unless you are correcting a wrongly defined CRS. This tool only tells QGIS 

how to interpret the raw coordinates; it does not change them. Using it on a layer with a 

correctly defined CRS will break its geolocation. 

  

To set explore this option following the guide in the figure below: 

 

3. Data Source Itself (the raw coordinates) 
These are the actual numbers stored in the file. For a shapefile in WGS84, the coordinates are in decimal 

degrees. For a file in a UTM projection, the coordinates are in meters. 

  

To explore this option, follow the guide in the figure below: 

  

 



 
 

Exercise: on Exploring Map projections 
In this exercise, we will open layer (https://mercator.elte.hu/~ungvarizs/oktatas/qgis/14.zip) in QGIS 

and set project CRS to EPSG: 3410. NSIDC EASE Grid Global – (an equal-area projection). 

  

Add this layer in QGIS, at this stage you will see something like the Figure below: 

 
The project and the layer CRS is not the target CRS (EPSG: 3410). It is EPSG: 4326, QGIS calls 

Latitude/longitude WGS84. It is an equidistant cylindrical projection using the WGS84 ellipsoid of 

revolution and geographic coordinates. 

To set the project CRS, follow the procedures in the guideline in the figure below: 

https://mercator.elte.hu/~ungvarizs/oktatas/qgis/14.zip


 
Open the Project properties → CRS window. Type in to Filter: 3410. In the bottom section of the 

window, all results will appear. Find the projection according to their EPSG and name, finally click 

Apply and OK in this window. 

Now your project CRS is EPSG: 3410. 

 
But the layer projection is 4326. If you want to Save the layer in the new projection → Right-click on 

the layer → Export → Save Features As…  

Select the file format e.g. Esri Shapefile, set the folder and the filename, and set CRS to 3410.  



 
After saving, check the content of the PRJ file. PRJ is a text file format, which stores the projection in 

”WKT Style” format.  

 

What is EPSG:3410? 
EPSG:3410 is a global, equal-area projected coordinate reference system. It was developed by 

the National Snow and Ice Data Center (NSIDC) to facilitate the mapping and analysis of global data, 

with a particular focus on the polar regions. 

Its full name is "NSIDC EASE-Grid Global", where EASE-Grid stands for Equal-Area Scalable 

Earth Grid. 

Key Characteristics and Properties 

Equal-Area (Equivalent) 

This is the most important property. 

• Any area on the Earth's surface, whether at the equator or the poles, is represented by the same 

area on the map grid. 

• This makes it ideal for quantitative analysis of phenomena that are measured by area, such as: 



o Sea ice extent and concentration 

o Snow cover 

o Vegetation density (e.g., NDVI) 

o Land use / land cover change 

• Unlike Web Mercator (EPSG:3857), it does not exaggerate the size of polar regions. 

  

When to Use It 

• Primary Use: Working with NSIDC data products. If you download sea ice concentration, 

snow water equivalent, or soil moisture data from NSIDC, it will almost certainly be in an 

EASE-Grid (either the original EPSG:3410 or the newer EASE-Grid 2.0). 

• Any global equal-area analysis: If you need to calculate the total area of a global phenomenon 

(e.g., global forest cover change), this projection is an excellent choice. 

When NOT to Use It 

• Navigation or general-purpose world maps: The distorted shapes make it unfamiliar and 

unsuitable for general reference. 

• Measuring distance or direction: It is not equidistant or azimuthal (despite being based on an 

azimuthal projection), so distances and directions are not preserved accurately across the entire 

map. 

• Creating local or regional maps: For a specific country or region, a local equal-area projection 

(like Albers Equal-Area Conic) will have far less distortion. 

  

EPSG.IO website 
This website collects plethora of reference systems and their related information such as description and 

projection files in different file formats. Let’s explore 3410 on this website:  

https://epsg.io/map#srs=3410&x=13102842.264680&y=-

650667.521429&z=1&reproject=1&layer=streets 

 

Try other map projections in QGIS 

EPSG:53012 refers to Sphere Eckert IV, the Eckert IV projection (Sphere) is an equal-area, 

pseudocylindrical map projection used primarily for thematic world maps. Introduced by Max Eckert in 

1906, it features a central meridian half the length of the Equator and poles that are straight lines.  

Sphere Bonne EPSG:53024 
The Bonne projection offers a unique way to flatten the Earth. It has the worst distribution of angular 

distortions among all conventional map projections; thus, its usage should be constrained to decorative 

purposes. 

Key Properties and Distortion: The projection maintains accurate angles along the central meridian 

and the standard parallel, with distortion rapidly increasing away from these lines. Scale is true along 

the central meridian and all parallels. 

  

North Pole Azimuthal Equidistant EPSG: 102016 
It is a projected coordinate system that uses the Azimuthal Equidistant projection, centered on 

the North Pole. Its key feature is that it preserves both distances and directions from the central point. 

  

What "Azimuthal Equidistant" Means? 

1. Azimuthal: Preserves direction (bearing). A straight line from the center point (the North 

Pole) to any other point on the map shows the true direction, or azimuth. This is crucial for 

navigation. 

2. Equidistant: Preserves distance. The scale is true only along lines radiating from the central 

point. This means you can accurately measure the distance from the North Pole to any other 

location on the map. 

  

https://epsg.io/map%23srs=3410&x=13102842.264680&y=-650667.521429&z=1&reproject=1&layer=streets
https://epsg.io/map%23srs=3410&x=13102842.264680&y=-650667.521429&z=1&reproject=1&layer=streets


Pseudo-Mercator EPSG: 3857 
It is a projected coordinate reference system (CRS) based on the Mercator projection. It's the de facto 

standard for displaying maps on the web, used by Google Maps, Bing Maps, OpenStreetMap, and 

countless other web mapping services and applications. 

Its official, full name is "WGS 84 / Pseudo-Mercator. 

  

1. Projection Type: Mercator 

• It is almost a conformal projection, meaning it distorts local   angles only slightly.  

• It is a cylindrical projection, where the standard parallel is at the Equator. 

2. Units: Meters 

• Unlike a Geographic CRS (which uses degrees), the coordinates in EPSG:3857 are in meters. 

This makes it a projected coordinate system. 

• The world is projected onto a square with the following approximate bounds: 

o X (Easting): -20,037,508 m to +20,037,508 m 

o Y (Northing): extending  from negative to positive infinity. 

• The origin (0,0) is at the intersection of the Equator and the Prime Meridian. 

3. The Most Famous Consequence: Severe Area Distortion 

Like all Mercator projections, EPSG:3857 drastically distorts area as you move away from the 

Equator. 

• Greenland appears to be roughly the same size as Africa, when in reality, Africa is about 14 

times larger. 

• Antarctica is stretched into a massive, unrecognizable strip across the entire bottom of the map. 

• This makes it unsuitable for thematic maps showing area-based data (e.g., population density, 

land use) at a global or continental scale. 

4. Why is it So Ubiquitous in Web Mapping? 

Despite its distortions, it became the standard for several practical reasons: 

• Conformality: Preserving small shapes is critical for viewing features like streets, buildings, 

and coastlines. They look "correct" and recognizable at any location on the map. 

• "North-Up" Rectangular Grid: The Pseudo-Mercator is a cylindrical projection, meaning 

north is always "up." This creates a consistent, square grid that is perfectly suited for tiling. 

• Simple Tiling System: The projected world is usually cropped into a square frame, which 

makes it mathematically trivial to divide the map into a pyramid of image tiles (e.g., 256x256 

pixel squares) at different zoom levels. This is the foundation of all modern web map services. 

• Early Adoption & Network Effect: Google Maps adopted it early on, and others followed to 

ensure compatibility. Now, all mapping libraries (Leaflet, OpenLayers, Google Maps API) 

expect this CRS by default, creating a powerful standard. 

  

1. Recognition 

In QGIS, you will see it under these names: 

• EPSG:3857 

• WGS 84 / Pseudo-Mercator 

• Web Mercator 

2. When to Use It 

• Creating background maps for web applications. 

• Overlaying your data on top of Google Maps, Bing, or OSM basemaps. 

• Any time you need seamless compatibility with web mapping standards. 

3. When NOT to Use It 

• Measuring areas or distances over large regions. The measurements will be highly inaccurate. 

• Performing spatial analysis that relies on accurate areas or distances. 

• Creating thematic maps where the relative size of countries/regions is important. 

Best Practice in QGIS: Use EPSG:3857 for visualization and web publishing, but reproject your layers 

to a local, equal-area projection for any measurement or analysis. 

  



What is EPSG:4326? 
EPSG:4326 is a Geographic Coordinate Reference System (CRS). Unlike projected systems like 

Web Mercator (EPSG:3857), it does not use a map projection. Instead, it defines locations directly on 

the ellipsoidal model of the Earth. 

Its official name is "WGS 84" (World Geodetic System 1984). 

  

Think of EPSG:4326 as the planet's natural coordinate system. It uses a simple, global grid: 

• Longitude (axis X): Measures the angle east or west of the Prime Meridian (0°), which runs 

through Greenwich, London. 

o Range: -180° to +180° (West to East). 

• Latitude (axis Y): Measures the angle north or south of the Equator (0°). 

o Range: -90° to +90° (South to North). 

The units are always decimal degrees. 

A coordinate in EPSG:4326 looks like this: (longitude, latitude) 

• Example (Eiffel Tower): (2.2945, 48.8584) 

  

Key Characteristics of EPSG:4326 

1. It's Not Projected 

This is the most critical distinction. Because it's a geographic system, it does not flatten the Earth. It 

simply provides a reference system on the curved surface. When you see data in EPSG:4326 displayed 

on a flat screen, your GIS (like QGIS) is projecting it on-the-fly for you. 

  

2. The Universal Datum: WGS 84 

The "WGS 84" part is the geodetic datum. A datum is a model that defines the size, shape, and origin 

of the Earth. WGS 84 is the standard global datum with the following key features: 

• Defines the Earth as an ellipsoid (a slightly squashed sphere). 

• Provides a fixed origin for the coordinate system that is consistent worldwide. 

• It is the datum used by the Global Positioning System (GPS). Your smartphone's GPS 

receiver provides locations in WGS 84 (EPSG:4326) by default. 

  

3. Distortion is Inherent 

Since it's not projected, a degree of latitude and a degree of longitude do not represent the same physical 

distance everywhere, but it also varies slightly. 

• A degree of latitude is relatively consistent, approximately 111 km (69 miles) everywhere. 

• A degree of longitude changes dramatically: 

o At the Equator: ~111 km 

o At 45° Latitude: ~79 km 

o At the Poles: 0 km 

This means that geometry and measurements in degrees are inherently distorted. 

 

Hungarian EOTR map sheets and Hungarian EOV projection 
EOTR stands for Egységes Országos Térképrendszer, which translates to Unified National Map 

System — Hungary’s official topographic map sheet system. 

EOTR divides Hungary into a grid of rectangular map sheets, each identified by a unique EOTR 

code (e.g., 88-324, 34-412, etc.). 

These codes correspond to a fixed coordinate-based grid built on Hungary’s EOV (Egységes 

Országos Vetület) projection — that is, the Hungarian national coordinate system (EPSG:23700). 

Each sheet covers a specific geographic area: 

• At 1:10 000 scale, one EOTR sheet typically covers 6 km × 4 km on the ground. 

 

Coordinate System 

• Projection: EOV (Egységes Országos Vetület) 

• Datum: HD72 (Hungarian Datum 1972) 

• EPSG code: EPSG:23700 



Typical Uses 

• Cadastral and land registry mapping 

• Environmental and hydrological studies 

• Infrastructure and regional planning 

• Archival topographic maps (used by military, surveyors, and GIS specialists) 

 

Example 

An EOTR sheet labeled “88-324” refers to: 

• Zone 88 (the grid row and column in the EOTR system) 

• Sheet 324 (specific map tile within that zone) 

Each code can be precisely located using EOV coordinates. 

  

The EOV projection (Egyseges Orszagos Vetulet) is the official national projected coordinate system 

for Hungary. It is a conformal projection based on the Hotine Oblique Mercator method, designed to 

provide high accuracy for surveying and mapping across the entire country. 

  

This projection uses a mapping similar to the Swiss Oblique Mercator,  and is conformal, meaning it 

preserves local angles accurately. It's based on the Hungarian Datum 1972 using the GRS 1967 ellipsoid. 

  

The projection center is located accurately at latitude 47.1444° North and longitude 19.0486° East. It 

uses false easting and northing values of 650,000 meters and 200,000 meters respectively, with a scale 

factor of 0.99993. All coordinates are measured in meters, and the system is designed specifically for 

use across Hungary. 

  

This uniform coordinate system provides high accuracy for surveying, engineering, and mapping 

applications throughout the country. 

  

  

More about the Hungarian EOV projection can be read in this note. It can be found in the page 53 

(Hotine projection): 

https://mercator.elte.hu/~kerkovits/honlap/diasor/proj.pdf   

Georeferencing of an EOTR map sheet 

Georeferencing 
In simple terms, georeferencing is the process of assigning real-world geographic coordinates to a 

raster image or a scanned map that lacks spatial reference. 

Let’s assume you have a simple JPEG image of an old, paper map. Your computer sees it as just a 

picture—a collection of pixels. Georeferencing "trains" the GIS software to where this picture belongs 

on the surface of the Earth. It defines where the top-left corner, bottom-right corner, and every point in 

between are located in a known coordinate system (like Latitude/Longitude, UTM, etc.). 

  

Once georeferenced, that image can be: 

• Viewed alongside other spatial data (e.g., satellite imagery). 

• Used as a background for digitizing features. 

• Analyzed spatially. 

  

Why is Georeferencing So Important? 
1. Using Scanned and Historical Maps: This is the most common use. Old paper maps are 

invaluable resources. Georeferencing them allows us to see how coastlines have changed, how 

urban areas have expanded, or how land use has evolved over time. 

2. Incorporating Aerial and Satellite Imagery: Raw aerial photographs often don't have a spatial 

reference built in. Georeferencing corrects them so they align perfectly with other map data. 

https://mercator.elte.hu/~kerkovits/honlap/diasor/proj.pdf


3. Data Integration: It allows disparate datasets to be layered accurately. You can't analyze the 

relationship between, say, soil types and crop yields if the underlying maps aren't aligned. 

4. Digitizing Base: A georeferenced map serves as a perfect background layer for "heads-up 

digitizing," where you trace over features to create new vector data (points, lines, polygons). 

  

The Core Process: How Georeferencing Works 
The process is essentially a digital version of "rubber-sheeting"—stretching and warping the image to 

make it fit known positions. 

Here are the standard steps: 

1. Load the Raster: Open your non-referenced image (e.g., a scanned map, a JPEG of a site plan) 

into your GIS software (like QGIS, ArcGIS, Global Mapper). 

2. Identify Ground Control Points (GCPs): This is the most critical step. You find identifiable 

points on your raster image that you can also locate precisely on a already-referenced map or 

dataset. 

• Good GCPs: the best if you put the control point in the crosses of the map/geographic grid. In 

lack of grid, you can use road intersections, building corners, distinct landmarks, river 

confluences, survey benchmarks, where the coordinates are known. 

• On the Image: You click on the point. 

• On the Map:(If there is) You either type in the known coordinates or click on the same point 

on a referenced layer to "assign" the coordinates. 

  

1. Choose a Transformation Method: The software uses the GCPs to calculate a mathematical 

formula to warp the image. The number and quality of GCPs determine which transformation 

you can use. (Source: QGIS website). 

o The Linear algorithm is used to create a world file and is different from the other 

algorithms, as it does not actually transform the raster pixels. It allows positioning 

(translating) the image and anisotropic scaling, but no rotation or other transformations. 

It is the most suitable if your image is not rotated at all, i.e., it is not scanned, but 

designed by computer, in a known CRS, but is just missing georeferencing information. 

At least 2 GCPs are needed. 

o The Helmert transformation also allows rotation. It is particularly useful if your raster 

is a good quality local map or orthorectified aerial image, but not aligned with the grid 

bearing in your CRS or or your map has been rotated slightly during scanning. At least 

2 GCPs are needed. 

o The Polynomial 1 algorithm allows a more general affine transformation, in particular 

also a uniform shear. Straight lines remain straight (i.e., collinear points stay collinear) 

and parallel lines remain parallel. This is particularly useful for those old maps, where 

the paper was stretched in one direction. At least 3 GCP’s are required. 

o The Polynomial algorithms 2-3 use more general 2nd or 3rd degree polynomials 

instead of just affine transformation. This allows them to account for curvature or other 

systematic warping of the image, for instance photographed maps with curving edges. 

At least 6 (respectively 10) GCP’s are required. Angles and local scale are not preserved 

or treated uniformly across the image. In particular, straight lines may become curved, 

and there may be significant distortion introduced at the edges or far from any GCPs 

arising from extrapolating the data-fitted polynomials too far. 

o The Projective algorithm generalizes Polynomial 1 in a different way, allowing 

transformations representing a central projection between 2 non-parallel planes, the 

image and the map canvas. Straight lines stay straight, but parallelism is not preserved 

and scale across the image varies consistently with the change in perspective. This 

transformation type is most useful for georeferencing angled photographs (rather than 

flat scans) of good quality maps, or oblique aerial images. A minimum of 4 GCPs is 

required. 

o Finally, the Thin Plate Spline (TPS) algorithm “rubber sheets” the raster using 

multiple local polynomials to match the GCPs specified, with overall surface curvature 

minimized. Areas away from GCPs will be moved around in the output to accommodate 



the GCP matching, but will otherwise be minimally locally deformed.  TPS is most 

useful for georeferencing damaged, deformed, or otherwise slightly inaccurate maps, or 

poorly orthorectified aerials.  It is also useful for approximately georeferencing and 

implicitly reprojecting maps with unknown projection type or parameters, but where a 

regular grid or dense set of ad-hoc GCPs can be matched with a reference map layer. It 

technically requires a minimum of 10 GCPs, but usually significantly more to be 

successful. 

2. Set Resampling Method: When the image is warped, the pixels have to be reassigned to new 

locations. The resampling method determines how the pixel values are calculated. 

o Nearest Neighbor: Fastest, preserves original pixel values. Best for categorical data 

(like classified images). 

o Bilinear Interpolation: Smoothens the image by averaging 4 nearby pixels. Better for 

continuous data (like aerial photos). 

o Cubic Convolution: Averages 16 nearby pixels, producing the smoothest result but is 

computationally intensive. 

o Lanczos (6×6 kernel) 

3. Set the Output raster 

4. Play the Transformation 

  

Key Considerations & Challenges 

• GCP Quality is important: The accuracy of your final product is directly dependent on the 

accuracy and distribution of your GCPs. A few well-distributed points are better than many 

clustered points. 

• Source Map Accuracy: You cannot make a georeferenced map more accurate than the original 

source map. If the original cartographer make errors, those shall remain. 

• Distortion: All paper maps distort due to stretching, shrinking, and aging. The transformation 

tries to correct for this, but it's an approximation. 

• Coordinate System: You must know which coordinate system (projection and datum) to use 

for your GCPs. Using the wrong one will result in significant misalignment. 

  

For further reading: Georeferencing raster images in QGIS  

 

Exercise 
In this exercise, we will import this image File as a raw raster file and Georeference it with 4 Ground 

Control Points. To do this follow the guides below: 

  

1. First, open raw raster File in image viewer application (e.g. Windows Photo Viewer). 

Understand the map sheet!  

2. EOTR Map Sheets contains two types of coordinates: Hungarian EOV Coordinates are written 

between the two frame lines with bigger font size. And the outer numbers were used in an earlier 

Hungarian map projection (called stereographic projection). These numbers are outside of the 

frame with smaller font size. Focus only on the EOV coordinates.  

 
3. The Hungarian EOV coordinates are approximately  

x>400,000 (Vertical coordinates/East/Easting) 

y<400,000 (Horizontal coordinates/North/Northing) 

https://docs.qgis.org/3.44/en/docs/user_manual/managing_data_source/georeferencer.html


 The unit is meter. If you read 642 or 156 in the map, that means the 642,000 an 156,000. 

4. Georeference the map in QGIS: Layer → Georeferencer. In Georeferencer window → File → 

Open Raster. Open the 35-124.jpg. 

 
5. Set Transformation Settings 

• Open via the gear icon. For 4 points, use Linear or Polynomial 1  transformation (minimum 3 

points)-  

• Set Target SRS (Coordinate Reference System). EPSG: 23700 Hungarian HD72/EOV 

projection. 

• Give the Output file name and the compression type: LZW (Lempel-Ziv-Welch is a lossless 

compression type) in GeoTiff. 

• File format is GeoTiff. 

  

At this point, you will see something like the Figure below: 

 
6. Add Ground Control Points (GCPs): Click Add Point tool. Place a point on the image, then 

enter coordinates manually or pick from map canvas. Add the point in the crossing of grid lines. 

Add four GCP-s, these are the corner points of the map. 

The assigned coordinate system is also EPSG:23700. 



Ground Control Point (GCP): This is a point you create by linking a location on your non-

georeferenced image (e.g., a scanned map, an aerial photo) to a known coordinate in a real-

world coordinate system (e.g., from a basemap like OpenStreetMap or a GPS survey). 

o From: Pixel X, Pixel Y on your image. 

o To: Map X, Map Y in a CRS (like EPSG:4326). 

 

 
Finally, you will see the following result in the GCP table: 

 
The Source X and Source Y means the target pixel coordinates on the image. Dest(ination). X and Dest. 

Y means the point coordinates is the given coordinate system. dX and dY are the residuals, that is the 

average estimated error of given points.  

 

What is residual? (=estimated error) 
 

In QGIS georeferencing, a residual is the calculated difference between where a Ground Control 

Point (GCP) actually ends up after a transformation and where it was supposed to go. In short: The 

residual is the "goodness of fit" for each individual GCP. 

How to Interpret Residuals in QGIS? 

In the QGIS Georeferencer window, you will see a table with your GCPs and their associated residuals. 

• Low Residual Value (e.g., 0.5 meters): This indicates that the GCP is a very good fit for the 

chosen transformation model. The point was placed accurately. 

• High Residual Value (e.g., 15.7 meters): This is a red flag. It means this particular GCP is 

significantly "pulling" against the other points. It is an outlier and is degrading the overall 

accuracy of the georeferencing. 

 

 

7. Save GCPs & Start Georeferencing as as described in the Figures above. 

• Save points via File → Save GCP Points As for backup. 

• Click Start Georeferencing (green arrow) to create the output file. 

   



Transformation Algorithm: When you start the georeferencing process, QGIS uses a mathematical 

model (e.g., Polynomial 1, Helmert, Thin Plate Spline) to warp and stretch your image so that all the 

GCPs align as closely as possible with their target coordinates. 

  

Now, you can see the georeferenced map in the main QGIS window. Check, whether the coordinates 

are right and the CRS is EPSG:23700.  

Now, let’s crop everything outside the map! Right click on layer → Export → Save As… 

 
 

  

When exporting the raster file, set layer extent to N = 156,000; S =152,000; W = 642,000; E = 648000. 

Beside the extent, set the CRS to EPSG:23700 and give the filename. 

At this stage, you will see something like the figure below: 

 
 



Vectorization of a raster map layers 

Creating and drawing point layer 

This is a digitization exercise; we will use EOTR Map sheets to digitize point, line, and polygon features. 

We will use CRS: EPSG 23700. 

  

1. Creating a Geopackage 

• Go to Layer → Create Layer → New Geopackage Layer 

• In the dialog box that opens, click the ... button next to Database and choose whether to create a 

new file or select an existing one. Give it a name and save it. 

• Enter a Table name for your first layer. 

• Define the layer's properties: 

o Geometry Type: Choose from Point 

o CRS: Click Specify CRS to set the Coordinate Reference System (EPSG: 23700) 

• Add fields (attributes) to your table by entering a Name (Spot Height), selecting a Type (Text), 

and Elevation, select data type (Decimals).  Click on Add to Fields List. 

• Click OK to create the GeoPackage and the new layer. 

At this stage, you will see something like the figures below: 

 
 



 
 

 
 



 
Note: Attributes are the name and elevation. In the EOTR map sheet, you can find spot heights: every 

cases the point has an elevation and it sometimes has a name e.g. 65-3223.  

  

Exercise: How to Add point feature with attribute 
Add Georeferenced EOTR sheet in QGIS, at this stage you will see something like the figure below: 

 
To add a point feature (Spot height and its elevation), follow the guide in the figure below: 

1. Select the layer in the layer tree.  

2. Take the layer editable. Click on Toggle Editing. 

3. Add new point feature 

4. Click on map, and give the location of the point 

5. Give the attributes, OK. 



 
If all new data were added to the layer, finish the editing with Save Layer Edits. Deactivate the layer 

editing, click on the „pencil” icon. 

 
Now, you can see the new features in the attribute table as well. 



 
Other editing tools 

How to Move item (Vertex tool) 

1. Start an Editing Session: First, you need to put the layer into edit mode. In the Layers panel, 

right-click on your point layer and select Toggle Editing, or click the yellow pencil icon on 

the Digitizing Toolbar. 

2. Select Your Points: Use the Select Feature(s) tool (the standard arrow icon) to click on the points 

you want to move. To select multiple points, hold down the Shift key while clicking, or drag a 

box around them. 

3. Go to the top menu and select Edit → Edit Geometry  

4. Alternatively, Using the Vertex Tool: On the Digitizing Toolbar, click the Vertex Tool icon (a 

red point with a mouse cursor). The vertices (points) will become visible. Click and drag a 

rectangle over the points you want to move to select them, then click on any selected vertex and 

drag them to the new spot. 

  

Save Your Changes: Your edits are not permanent until you save them. Click the Save Layer 

Edits button (a floppy disk icon) on the Digitizing Toolbar. You can also click the Toggle Editing button 

again to stop editing, which will prompt you to save or discard your changes. 

 These steps can be done by following the figure below: 



 
 

 



 
 

How to Delete features 

Toggle Editing: First, you need to put the layer into edit mode. 

• In the Layers Panel, right-click on your point layer. 

• Select Toggle Editing. Alternatively, you can click the yellow pencil icon on the Digitizing 

Toolbar. 

Select the Feature(s): Use the Select Feature(s) tool (the standard arrow icon) from the toolbar. 

• To select a single point, simply click on it. It will turn a different color (usually yellow). 

• To select multiple points, hold down the Shift key while clicking on them, or drag a box around 

the points you want to delete. 

Go to the top menu and select Edit → Delete Selected. 

At this stage, you will see something like the figures below: 



 
 

 



 
How to Modify attribute 

 

1. Enable Editing: In the Layers Panel, select your point layer. On the Attribute Table toolbar, 

click the "Toggle editing" button (it looks like a yellow pencil).  

2. Open the Attribute Table: With the layer selected, click the "Open Attribute Table" button (table 

icon) on the same toolbar. You can also right-click the layer in the Layers Panel and 

choose "Open Attribute Table"  

3. Choose Your Editing Method: Once the table is open, you can modify data in several ways:  

• Direct Typing: Simply double-click on any cell in the table and type in the new value 

Save Your Edits: This is a crucial step. Click the "Save Layer Edits" button (floppy disk icon) on the 

Attribute Table toolbar to make your changes permanent. 

 



 
 

 



 
Note: If you try to close the table or turn off editing without saving, QGIS will prompt you to save or 

discard your changes! 

Creating and editing a line layer 

How to create a new LineString layer as a Geopackage  

  

1. Go to Layer → Create Layer → New GeoPackage Layer. 

2. Click … by "Database". Choose to create a new file or use an existing one. QGIS adds 

the .gpkg extension. For our case, we will use the same Geopackage we used to digitize Spot 

Heights. 

3. Enter a Table name for your layer within the GeoPackage. 

4. Set Geometry type to LineString or MultiLineString. 

5. Click Select CRS (Coordinate Reference System) and pick the correct one for your map. Set 

EPSG: 23700. 

6. In the Fields section, create attribute fields ("name" as Text, "Elevation" as Decimal). 

Enter Name, select Type, and click Add to Fields List. 

7. Click OK. The new layer appears in Layers Panel, ready for editing. 

8. Do not overwrite the geopackage! Add new layer to the Geopackage. 



 
 

 
Now, we will digitize the contour lines with elevation (attribute), and give the type of the contour (main, 

normal). 

  

How to draw new line feature 

1. Start Editing: Select your new layer in the Layers Panel and click the yellow pencil icon 

to Toggle Editing. 

2. Draw Lines: Click the Add Line Feature icon (a pencil drawing a line). Click onto the map 

canvas to place vertices. Right-click to finish the line. 

3. Enter Attributes: A dialog will prompt you to enter the attribute information for the new line 

feature. 

4. Save Edits: Click the Save Layer Edits icon (floppy disk) to save your changes to the layer. 

Click the yellow pencil again to exit editing mode. 

  

At this stage, you will see something like the figure below: 

 



 
 

 
Now, create another line string layer in the same Geopackage Normal Contour, and follow the same 

procedure to digitize Normal Contour. 

  

Note: In topographical maps, Contours are categorized into Main Contour and Normal Contours. 

  

  

How to Delete one node while you draw (backspace) 

  

When drawing a linestring in QGIS, you can delete the last vertex you placed by simply pressing 

the Backspace key. This works while you are actively drawing the feature, right before you finish it by 

right-clicking. 

  

How to move node with vertex tool 

  

1. Select your layer in the Layers Panel. Click the yellow pencil icon (Toggle Editing) to start 

editing the layer. 



2. Open the Digitizing Toolbar, then click the Vertex Tool icon. For more precision, use Vertex 

Tool (Current Layer) to only edit the selected layer. 

3. Click on the feature you want to edit to show its vertices. Click on a vertex to select it (its color 

will change), then drag it to the new location. 

4. Click the Save Layer Edits icon (floppy disk) to save your changes. Click the yellow pencil icon 

again to exit editing mode. 

 
 

 



 
How to delete line 

  

1. Make sure your layer is in editing mode by clicking the Toggle Editing (yellow pencil) icon. 

2. Click the Select Features tool (arrow icon) and click on the line you want to delete. Selected 

lines will appear highlighted in yellow. 

3. Press the Delete key on your keyboard, OR right-click the layer and choose Delete Selected, 

OR use the Edit menu → Delete Selected. 

4. Click the Save Layer Edits icon (floppy disk) to make the deletion permanent. 

 

 



 

Activate Advanced digitizing toolbar and Snapping toolbar 
  

To activate the Advanced Digitizing toolbar, follow these steps: 

  

1. In the top menu, click on View. 

2. Select Toolbars from the dropdown menu. 

3. In the list of toolbars, check the box next to Advanced Digitizing Toolbar. 

The toolbar should now appear on your screen, typically near the top of the QGIS interface. 

  

To do this, follow the procedures in the figure below: 

 



 

Snapping 
  

In QGIS digitization, snapping is a feature that automatically aligns the vertices or edges of the new 

feature you are drawing to those of existing features. This is crucial for creating clean, connected vector 

data without gaps or overlaps. 

  

To use snapping effectively, you need to enable it and configure the options to suit your task. 

  

1. Enable the Toolbars: First, ensure the necessary toolbars are visible. Go to View → 

Toolbars and enable both the Digitizing Toolbar and the Advanced Digitizing Toolbar 

2. Open Snapping Options: Navigate to Project → Snapping Options.  

3. Configure Settings: In the snapping options window, click the magnet icon to enable snapping 

globally. 

 At this stage, you will see something like the figures below: 

 



 
What to Snap To: Choose to snap to vertices (points), segments(edges between points), or both. 

 
Snapping Tolerance: The distance within which snapping occurs. Can be set in pixels (on-screen) or 

map units (real-world). 



 
Snapping Layers: Configure snapping for all layers, only the active layer, or set different rules per 

layer using Advanced Configuration. 

 

Advanced configuration in snapping (opening snapping options) 
  

The Advanced Configuration mode in QGIS snapping is where you gain precise control, allowing you 

to set different snapping rules for each individual layer in your project. 

This is crucial when you are working with multiple layers and only want certain layers to snap to each 

other, or when different layers require different snapping tolerances. 

Layer: Displays the name of the layer. You cannot edit this column. 

  

Snapping (Checkbox): Enable/Disable: This checkbox turns snapping for this specific layer ON or OFF. 

A layer must be checked here to be able to snap to it. 

  

Type (Dropdown): What to snap to: Choose the geometry type of the target layer that will be snapped 

to. 

• Vertex: Snaps to the points/nodes of the features. 

• Segment: Snaps to the lines/edges between vertices. 



• Vertex and Segment: Snaps to both. This is the most common and flexible option.  

Tolerance (Value): The "magnetic" distance: How close your cursor needs to be to a feature for 

snapping to occur. 

How to measure the tolerance: 

• Pixels: The tolerance is a screen distance (e.g., 10 pixels). Good for on-screen consistency at 

different zoom levels. 

• Map Units: The tolerance is a real-world ground distance (e.g., 10 meters). This is often 

preferred for precision work. 

  

 
 

 



 
 

Advanced digitizing: Merge lines, Split feature 

Merge lines 
Let’s say you have several adjacent line segments (e.g., road parts, river segments) and you want to 

create one continuous line from them. 

It is described in the following figure for exercise what to do if you want to merge three road line 

segments; 1,2, and 3 into one Road layer segment. 

 
Steps: 

1. Start Editing: Click the yellow pencil icon on the Digitizing Toolbar. Select your line layer. 

Activate editing session to all three layers. 

2. Select the Lines: Use the Select Features tool (the standard arrow cursor) to select all the line 

segments you want to merge. Hold Ctrl to select multiple features. 

3. Open the Merge Tool: Go to the Edit menu → Merge Selected Features, or find the "Merge 

Features" icon in the Digitizing Toolbar. 

4. Save Edits: Click the Save Edits icon (the floppy disk). 

  



At this stage, you will see something like the figures below: 

 
 

 



 

Split feature 
Enable the Necessary Toolbars: 

First, ensure you have the right toolbars enabled: 

1. Digitizing Toolbar: Right-click the toolbar area and check Digitizing. 

2. Advanced Digitizing Toolbar: Check Advanced Digitizing for precision drawing. 

3. Snapping Toolbar: Check Snapping Toolbar. This is critical for accuracy. 

Configure Snapping: Click the magnet icon to enable snapping. Set it to snap to Vertex and Segment. 

This ensures your split points are exactly on the line. 

  

Let’s assume you want to split a main connecting road in the figure below into two parts: 

 
Steps: 

1. Start Editing: Click the yellow pencil icon on the Digitizing Toolbar. Select your line layer. 

Activate editing session to all three layers. 

2. Select the Line: Use the Select Features tool (the standard arrow cursor) to select all the line 

segments you want to merge. Hold Ctrl to select multiple features. 

3. Open the Split Tool: Go to the Edit menu → Split Selected Feature. 



4. A cursor will give you access to draw a line where you want to split your line, and right click 

option will split your layer. 

5. Save Edits: Click the Save Edits icon (the floppy disk). 

  

At this stage you will see something like the figures below: 

 
 

 



 
 

 
 Split Features: General purpose of splitting is to creates new, separate features. 

 

Creating and editing a polygon layer 

Creating a new multipolygon layer in the same geopackage file (as in the case in the 

point layer) 
  

1. Open the Data Source Manager: 

• Go to Layer in the top menu → Data Source Manager. 

• Or, press the Ctrl+L keyboard shortcut. 

• Or, click the corresponding icon in the left-hand toolbar. 

2. Select the GeoPackage Tab: 



• In the Data Source Manager window, click on the GeoPackage tab. 

3. Create a New Layer: 

• Click the New button (or in some versions, ... next to the Database field and browse to 

your existing GeoPackage file). 

4. Define the New Layer’s Properties: 

A new window, ”Create a New Layer within this GeoPackage,” will open. 

• Table Name: Enter a name for your new multipolygon layer 

• Geometry Type: From the dropdown menu, select MultiPolygon. 

• Coordinate Reference System (CRS): Click the Select CRS button (globe icon) and choose the 

same CRS as your point layer and map project for consistency. Set EPSG: 23700 

• Fields: Add the attribute fields you need for this layer. For example: 

o name (Type: Text) 

o area_km2 (Type: Decimal) 

• Create the Layer: 

o Click OK. The new, empty multipolygon layer will be added to your Layer. 

  

At this stage, you will see something like the figure below: 

 



 
 

 

Digitize the land cover (with type). 
First, ensure your multipolygon layer has a field for the land cover type. 

Open the Layer Properties: 

• Right-click your multipolygon layer in the Layers Panel 

• Select Properties → Fields tab 



 
Digitizing land use categories needs the determination existing land use categories. 

In this exercise, we will digitize 4 categories: Settlement, Grassland, Orchards, and Vineyard. 

 How to draw a new polygon feature 

• Make sure your multipolygon layer is selected in the Layers Panel 

• Verify you have the landcover_type field (or similar) for attribute data 

• Enable snapping for clean boundaries: 

o Go to View → Toolbars → make sure Snapping Toolbar is checked 

o Click the magnet icon to enable snapping 

o Set snapping to "Vertex and Segment" with ~10 pixels tolerance 

• Start Editing Session 

1. Select your multipolygon layer in Layers Panel 

2. Click the Toggle Editing button (pencil icon) or press Ctrl+E 

3. You will see the digitizing tools becoming active 

 



 
 

 
 



 
 

 



 
 

 



 
How to delete one node while you draw (backspace) 

Using Backspace to delete nodes while digitizing is essential for efficient editing. 

  

Step-by-Step Process: 

1. Start drawing your settlement polygon with the Add Polygon Feature tool 

2. Place several vertices by clicking around the area 

3. If you make a mistake or want to remove the last vertex: 

• Simply press the Backspace key (on Windows/Linux) or Delete key (on Mac) 

• Each press removes one previous vertex in reverse order 

4. Continue placing new vertices or finish with right-click 

  

How to move a node with the vertex tool 

  

Step 1: Activate the Vertex Tool 

1. Select your multipolygon layer in the Layers Panel 

2. Toggle Editing (pencil icon) if not already active 

3. Click the Vertex Tool (also called Node Tool) from the digitizing toolbar: 

Icon looks like a blue point with crosshairs or a node with arrows 



 
 

 



 
Delete polygon 

1. Select the Polygon: 

o Click the Select Feature tool (arrow icon) from the toolbar 

o Click directly on the polygon you want to delete 

o Selected polygon will be highlighted (usually yellow) 

2. Delete the Polygon: 

o Press the Delete key on your keyboard 

o OR right-click the layer → Delete Selected 

o OR click the Delete Selected button (trash can icon) 

3. Save Changes: 

o Click Save Layer Edits (floppy disk icon) 

o Toggle Editing (pencil icon) to stop editing session 

 

 



 
 

 



 
Activate Advanced digitizing toolbar and Snapping toolbar. 

  

Activating the Advanced Digitizing Toolbar 
Method 1: Through View Menu 

1. Go to View → Toolbars 

2. Check the box next to Advanced Digitizing Toolbar 

3. The toolbar will appear immediately in your interface  

 
  

How to open Snapping options 

Through the Main Menu 

1. Go to Project → Snapping Options 

2. Or go to Settings → Snapping Options (in older QGIS versions) 



 
 

 



 
How to activate advanced configuration in snapping (open snapping options): Topological editing, 

Avoid overlap on active layer → that helps the fast vectorization. 

  

Open the Snapping Options Dialog: 

• You can use the main menu: Project → Snapping Options 

• The window that opens is the Snapping Options dialog. This is your central control panel for all 

things snapping. 

1. Enable Snapping Globally 

At the top of the dialog, make sure the Enable Snapping box is checked. Without this, nothing 

else will work. 

2. Activate „Topological Editing” 

This is a crucial option for fast editing. 

o In the Snapping Options dialog, look for the section on the left side, just below the layer 

list. 

o Check the box that says Enable topological editing. 

What does this do? 

When this is on, QGIS doesn't just snap to the vertices and segments of the layer you are currently 

editing. It allows you to snap to the vertices and segments of all visible vector layers in your project. 

Even more importantly, when you move a shared vertex or segment between two polygons or lines, 

it will update both, maintaining the connection (topology). This is essential for creating seamless 

polygon layers without gaps or overlaps. 

  

 



 
 

 
 



 

Advanced digitizing: Merge polygons, Split feature, Draw an empty/filled hole, Draw 

parts 
  

Merge polygons 
1. Select the polygons you want to merge: 

• Use the Select Features tool (arrow icon) from the toolbar 

• Click on polygons while holding Ctrl to select multiple features 

2. Start editing mode: 

• Click the Toggle Editing button (pencil icon) 

• Or go to Layer → Toggle Editing 

3. Merge the features: 

• Click the Merge Selected Features button (icon showing two shapes merging) 

• Or go to Edit → Merge Selected Features 

4. Choose attributes: 

• A dialog will appear asking how to handle attributes 

• You can keep attributes from one of the original features or leave them empty 

• Click OK 

5. Save changes: 

• Click Save Layer Edits (disk icon) 

• Stop editing with the Toggle Editing button 



  
 

 



 
 

 
 

Split feature 
  

This is the go-to method for manually drawing a line to split one or more polygons. 

1. Start Editing Mode: 

• Select your polygon layer in the Layers Panel 

• Click the Toggle Editing button (pencil icon) 

• Or go to Layer → Toggle Editing 

2. Activate the Split Tool: 

• Click the Split Features button (scissors icon) 

• Or go to Edit → Split Features 

3. Draw the Split Line: 

• Click on the polygon boundary where you want to start splitting 

• Continue clicking to draw a line across the polygon 

• End the line by clicking on the opposite boundary of the polygon 



• Right-click to finish drawing 

4. Verify the Split: 

• You will see the polygon divided into two separate features 

• The new feature will be selected automatically 

5. Save Changes: 

• Click Save Layer Edits (disk icon) 

• Stop editing with the Toggle Editing button 

  

 
 

 



 
 

Draw an empty/filled hole 
  

Drawing an empty hole (also called an interior ring or donut) in a polygon is a common task in QGIS. 

This creates a hole inside a solid polygon. 

1. Start Editing Mode: 

• Select your polygon layer 

• Click Toggle Editing (pencil icon) 

2. Select the Polygon: 

• Use the Select Features tool (arrow icon) 

• Click on the polygon where you want to add the hole 

3. Activate Add Ring Tool: 

• Click the Add Ring button (looks like a doughnut or polygon with a hole) 

• Or go to Edit → Add Ring 

• Draw the Hole: 

• Click to place vertices for the hole inside the selected polygon 

• The hole must be completely inside the main polygon 

• Right-click to finish drawing 

4. Result: You now have a polygon with a hole! 



  
 

 
 

Shape digitizing toolbar  
This toolbar allows to draw special shapes rectangles (buildings), or circle (roundabout), etc. 

 

Draw special shapes 

 

1. Let’s open the Shape Digitizing Toolbar. 

2. Choose the shape (circle, ellipse, rectangle, other shapes) 

3. There are different drawing modes for each shapes. For example the circle can be drawn from the 

centerpoint while you are giving the radius.  

4. Test the different drawing modes! 

 

Note: The circle uses linestrings to represent the shape. So this shape is not a Bezier curve as in vector 

graphic software. QGIS cannot work with curves. 



 
 

 



 

Manual drawing of features - Vectorization of EOTR sheets 
  

Now, we have discussed how to digitize point, line, and polygon features, from basic to advanced 

digitization methods. You are expected to digitize an EOTR sheet. 

  

Key points to consider: 

1. Cover all features assigned 

2. Use Snapping options and the Advanced digitization toolbar to avoid Topological errors (I will 

explain in the sub-module what Topological errors are). 

3. You are Expected to read your EOTR sheet carefully to understand all Land cover types, 

Transportation elements, Hydrographic elements, Contours, Spot Heights. 

  

You are supposed to Create one Geopackage with the following layers:  

  

1. Spot heights (point layer, attributes: name (if there is), and elevation 

2. Contour lines: (line layer, attributes: type) 

Here Categorize Contours into Main Contours and Normal Contours. 

3. Hydrography (creeks): line layer, attribute: name (if there is) 

4. Roads (categorized road network (attribute: type): main road, street, motorway, highway, 

railway!).  Line layer 

5. Land cover: polygon layer. With correct topology (without any overlaps and gaps). 

  

Every student should digitize 2kmx 1km area. (this is two cells  in the EOTR sheet.). You will have 2 

weeks for this assignment. 

  

An the end, you are expected to produce a map which look like the figure below: 



 

Topology 

  

Topology is a set of rules that model the relationships between neighboring points, lines, and polygons 

and determine how they share geometry. 

For example, consider two adjacent polygons. In the spaghetti model, the shared boundary of two 

neighboring polygons is defined as two separate, identical lines. The inclusion of topology into the data 

model allows for a single line to represent this shared boundary with an explicit reference to denote 

which side of the line belongs to which polygon. 

 

For more information read these websites: 

https://docs.qgis.org/3.44/en/docs/gentle_gis_introduction/topology.html 

https://doc.esri.com/en/arcgis-pro/latest/help/data/topologies/an-overview-of-topology-in-arcgis.html 

 

Common Topological Errors: 

• Open or Unclosed polygon 

• Unlabeled polygon 

• Slivers 

• Undershoot or overshoot 

• Self intersections 

• Gaps between polygons 

 

https://docs.qgis.org/3.44/en/docs/gentle_gis_introduction/topology.html
https://doc.esri.com/en/arcgis-pro/latest/help/data/topologies/an-overview-of-topology-in-arcgis.html


 
Open or Unclosed polygon 

Open or unclosed polygons are one of the common topological errors that occur when an arc does not 

completely loop back upon itself. 

Unlabeled Polygon 

This is one of the common topological errors that occur when an area does not contain any attribute 

information, violating polygon-arc topology rules. 

Sliver 

Slivers occur when the shared boundary of two polygons does not meet exactly. 

Undershoot 

This is one of the topological errors that occur when two lines do not meet perfectly at a node. 

Overshoot 

This is one of the topological errors that occur when the line extends beyond the feature it should connect 

to. 

  

Topology Checker in QGIS 
  

The Topology Checker is a core QGIS plugin, meaning it's included with QGIS but may need to be 

enabled. 

  

1. Open QGIS. 

2. Go to the menu and select Plugins → Manage and Install Plugins 

3. In the dialog box, select the Installed tab. You can type "topology" in the search bar to find it 

quickly. 

4. Find "Topology Checker" in the list and check the box next to it. 

5. Click Close. The plugin is now enabled, and you can typically find it via Vector → Topology 

Checker 

  



 
 

 



 
 

 



 
 

Self-intersection error 
A self-intersection error (also called a "bowtie" or "inverted polygon" error) occurs when a polygon's 

boundary crosses over itself, creating an invalid geometry that can cause problems in spatial analysis 

and rendering. 

  

Using Topology Checker: 

1. Open Topology Checker (Vector → Topology Checker) 

2. Click Configure 

3. Add this rule: "must not have invalid geometries" 

4. Run Validate All 

  

 
  



 

 

Polygons with less than 3 nodes 
  

A "polygons with less than 3 nodes" error occurs when a polygon feature doesn't have enough vertices 

to form a valid shape. In GIS, a valid polygon must have at least 3 distinct vertices (forming a triangle). 

  

Topology Checker 

1. Open Topology Checker (Vector → Topology Checker) 

2. Click Configure 

3. Add rule: "must have valid geometry" 

4. Run Validate All - this will catch polygons with insufficient number of vertices 

  

  

Gaps between polygons 
  

A "gaps between polygons" error occurs when there are empty spaces between adjacent polygon 

features that should form continuous coverage without voids. This is a common topology issue in parcel 

maps, land cover data, and any continuous polygon datasets. 

  

Topology Checker  

1. Open Topology Checker (Vector → Topology Checker) 

2. Click Configure 

3. Add rule: "must not have gaps" 

4. Run Validate All - gaps will be highlighted in red 

 

 



 
 

Overlaps between polygons 
An "overlaps between polygons" error occurs when two or more polygon features share the same 

geographic space, creating duplicate coverage. This is a critical topology error that can lead to double-

counting in area calculations and inaccurate spatial analysis. 

 

 



 
 

Overshoots for lines 
  

An "overshoots for lines" error occurs when a line extends beyond its intended endpoint or intersection 

point. This is a common topology error in road networks, utility lines, rivers, and any linear network 

data where connectivity matters. 

  

Topology Checker 

1. Open Topology Checker (Vector → Topology Checker) 

2. Click Configure 

3. Add rule: "must not have dangles" 

4. Run Validate All - overshoots/undershoots will be highlighted 

  

 



 
 

Undershoots between  lines 
  

An "undershoots between lines" error occurs when a line fails to reach its intended connection point, 

leaving a gap in the network. This breaks connectivity and can cause serious issues in network analysis, 

routing, and flow calculations. 

  

Topology Checker 

1. Open Topology Checker (Vector → Topology Checker) 

2. Click Configure 

3. Add rule: "must not have dangles" (catches both overshoots and undershoots) 

4. Run Validate All - undershoots will appear as disconnected endpoints 

  

Important point to note: Topology Checker is a tool in QGIS, which helps to find these errors. The 

correction of errors needs human interactions. 

You will have to use Advanced vertex editing tools and Advanced digitization tools, with Snapping 

options and rules to correct all identified Topological errors. 

  

Make sure your data is free from topological errors. 

Manual Editing 

1. Toggle editing on the layer 

2. Select the problematic feature 

3. Use the Vertex Tool to: 

• Move intersecting vertices 

• Delete unnecessary nodes 

• Reshape the boundary to eliminate crossings 

• Remove overshoots and undershoots 

  

Fix Geometries Tool 

This algorithm attempts to create a valid representation of a given invalid geometry without losing any 

of the input vertices. Already-valid geometries are returned without further intervention. Always 

outputs multi-geometry layer. 

1. Processing → Toolbox 

2. Search for "Fix geometries" 

3. Run it on your problematic layer 



4. This automatically repairs most self-intersections, convert polygons to multipolygons 

  

First, identify a geometry "polygon" if exist in a multipolygons layer like land use. 

 
Then use "Fix Geometry" tool to fix this Geometry to Multipolygons. 

  



 

 
Prevention Tips 

• Use snapping when digitizing to avoid overlaps 

• Enable "Avoid intersections" in digitizing settings 

• Use "Trace polygon" tool for complex shapes 

• Regularly validate geometries during editing 

Digital terrain models – a short 

introduction 

Definition 
A digital terrain model is basically a database that contains the spatial coordinates (X, Y, Z) of 

certain points on a topographic surface. 

The topographic surface can be the Earth’s surface, or a geologic layer surface etc. 



A digital surface model can be created from different types of data, where the surface can be described 

by numbers, for example: meteorological data, population density etc. 

  

In the case of terrain depiction 
Digital surface model (DSM): contains object on the Earth’s surface and the objects on it (houses, 

forest). 

Digital terrain model (DTM): contains only the pure Earth’s surface 

Digital elevation model: common name 

 

Categorization of models 
Data types 

1. Raster: GRID models: 

Raster data is a type of digital data that uses a grid of cells or pixels to represent information. It is also 

known as grid or image data. Each cell in the grid represents a different value or attribute, such as 

pixel, elevation, temperature, or color. 

 
2. Vector: TIN models: Vector type data. Points are in an irregular network (horizontally), 

therefore every point’s X,Y coordinates have to be stored. +Z elevation. 

        
Global coverage 

1. Global & semi-global models 

These are the "big picture" models, covering the entire Earth or very large continental areas. 

• Spatial extent: The entire globe, a continent, or a major region (e.g., the entire Alps mountain 

range). 

• Data sources: 



o Satellite altimetry: Missions like SRTM (Shuttle Radar Topography Mission), 

ASTER GDEM, and TanDEM-X provide near-global coverage of elevation data. This 

is the primary source. 

o Satellite Lidar: Newer technologies like ICESat-2 provide highly accurate elevation 

profiles. 

o Compiled continental datasets: These are often created by stitching together regional 

datasets into a seamless global model. 

• Triangulation Characteristics: 

o Low resolution: The points (vertices of the grid) are spaced very far apart—often 30 

meters, 90 meters, or even 1 kilometer. 

o Highly generalized: A single pixel in a global model might cover an area larger than a 

city. It cannot capture fine details like a single hill or valley; instead, it captures the 

broad trend of the landscape. 

o Regularity: While a TIN is by definition irregular, the source data for global models is 

often a regular grid (a Raster DEM). This grid is then easily converted into a TIN, but 

the resulting triangles are often similar in size and shape across large areas. 

• Purpose & applications: 

o Continental-scale geological and climate studies. 

o Visualization in global mapping applications (e.g., Google Earth). 

o Flight simulation and planetary science. 

o Modelling ocean floor topography (bathymetry). 

  

2. Regional models 

 These models cover a medium-sized area, such as a watershed, a national park, or a county. 

• Spatial extent: A few square kilometers to thousands of square kilometers (e.g., the Thames 

River Basin, Yellowstone National Park). 

• Data sources: 

o Airborne Lidar: This is the gold standard. An airplane with a laser scanner flies over 

the region, collecting a massive, dense cloud of elevation points. 

o Aerial photogrammetry: Using stereo pairs of aerial photographs to derive elevation 

data. 

o Radar: Airborne or high-resolution satellite radar. 

• Dataset characteristics: 

o Medium to high resolution: Point spacing can be from a few meters down to sub-

meter. 

o Adaptive triangulation: The TIN becomes truly "irregular" here. The triangulation algorithm 

places more points in areas of complex terrain (steep slopes, ravines) and fewer points in flat 

areas. This efficiently captures the main topographic features like ridges, valleys, and hilltops. 

o Feature Inclusion: Breaklines (lines that enforce a ridge or a stream) are often added 

to the TIN to ensure that these critical landscape features are represented correctly in 

the model. 

• Purpose & applications: 

o Watershed and hydrological modelling (predicting water flow). 

o Regional planning and environmental impact assessments. 

o Forest and agricultural management. 

o Creating topographic maps. 

  

3. Local models 

These are highly detailed models of a small, specific site. 

• Spatial extent: A single construction site, a landslide, an archaeological dig, a single building, 

or a small quarry. Typically less than 1-2 square kilometers. 

• Data sources: 

o Terrestrial Laser Scanning (TLS): A ground-based scanner captures millions of 

points from a static position, creating an extremely dense point cloud of the immediate 

environment. 



o UAV/drone Lidar or photogrammetry: Drones can capture data at incredibly high 

resolutions (centimeters). 

o Total station & GPS surveying: For precise, targeted point collection. 

• Triangulation characteristics: 

o Very High/Ultra-High Resolution: Point density is extremely high, with spacing of 

centimeters. 

o Complex surfaces: The TIN can model not just the ground (a Digital Terrain Model - 

DTM) but also the surfaces of buildings, trees, and machinery (a Digital Surface Model 

- DSM). 

o Preservation of fine detail: The triangles are small and complex, capable of capturing 

individual curbs, foundation walls, erosion gullies, and large boulders. 

• Purpose & applications: 

o Civil engineering and construction earthwork volume calculations. 

o Monitoring slope stability and landslide movement over time. 

o Architectural documentation and heritage preservation. 

o Detailed flood modelling for a specific neighborhood. 

 

  

Working with SRTM in QGIS 

What is SRTM? 

SRTM (Shuttle Radar Topography Mission) is a global digital elevation dataset that was created using 

radar data collected by the Space Shuttle Endeavour in February 2000. It provides high-resolution 

elevation data of most of the Earth's land surface. 

Coverage: Nearly global, from 60°N to 56°S latitude (about 80% of Earth’s landmass). 

Resolution: 

    1 arc-second (~30 meters) – Available globally since 2014. 

    3 arc-seconds (~90 meters) – Available worldwide. 

Data format: Typically provided as GeoTIFF or HGT files. 

Accuracy: Vertical accuracy of ±16 meters. 

  

Beginning of measurent: 11th February 2000 and a 11 days mission with Endeavour space shuttle 

Technology used: Interferometric Synthetic Aperture Radar (InSAR) from two radar antennas on the 

Space Shuttle. 

 
Source of figure: https://en.wikipedia.org/wiki/Shuttle_Radar_Topography_Mission 

The data is not projected, using a Geographic (Lat/Long) coordinates on the WGS84 horizontal datum 

and the EGM96 vertical datum. 

The dataset is available in two different resolution: 



https://dwtkns.com/srtm30m/  

https://portal.opentopography.org/raster?opentopoID=OTSRTM.042013.4326.1/ 

 

Exercise 
Load the srtm.tif into QGIS. 

1. Go to Layer → Add Layer → Add Raster Layer 

2. Click Browse, select your .tif file, then Add 

This GeoTiff file contains elevations in their pixels. It has only one Band. 

 
Use Identify feature tool to read the heights from the raster layer. Set focus on the elevation layer, and 

click on Indentify Features. Click somewhere on the layer, and read the height in the window. 

  

 

Creating a hypsometric tint 
In discrete hypsometric tinting, the elevation ranges are divided into distinct, non-overlapping 

intervals. Each interval is assigned a specific color or shade that represents the elevation range within 

that interval. The color scheme uses distinct colors for each range, making it easy to visually distinguish 

https://dwtkns.com/srtm30m/
https://dwtkns.com/srtm30m/
https://csidotinfo.wordpress.com/data/srtm-90m-digital-elevation-database-v4-1/


between different elevation levels. For example, green might represent low elevations, yellow for mid-

elevations, and brown for high elevations. 

  

We will put elevation levels to 100, 200, 300, 500, 700 m. Open the layer Properties → Symbology → 

Render type → Set to Singleband pseudocolor. 

 
Set Discrete coloring in Interpolation. In the box below, add the above mentioned elevations to the list. 

Add values manually (green plus icon). Set the color as well. Labels are the text displayed in the Legend. 

 



 
 

 



 
 

 
 Save the color scale into a text file. Click on the „floppy” icon (Export color map to file), and set the 

path of the textfile.This textfile can be reused in other projects. 

 



 
 

 
To load your previously designed color ramp, follow the guide in the figure below, click on Load color 

map from file (folder icon) and give the location of the color ramp text file.  



 
In continuous hypsometric tinting, a smooth gradient of colors is used, where the color transitions 

gradually between elevations. There are no distinct intervals; instead, the color changes continuously to 

represent the full range of elevations. The map uses a smooth color gradient, often ranging from light 

green for low elevations to dark brown or white for the highest elevations. The elevation values are 

represented on a continuous scale, allowing for a more detailed and nuanced representation of terrain. 

This method offers a fine-tuned visualization of elevation changes, showing gradual shifts in terrain 

rather than discrete, hard boundaries between elevation zones. 

To set continuous hypsometric tinting, follow the guide in the figures below. 

Open the layer Properties → Symbology → Render type → Set to Singleband pseudocolor. Interpolation 

method: Linear. 

 



 
 

 



 

Comparing the discrete and linear (continous tints) 

Feature Discrete Hypsometric Tint Continuous Hypsometric Tint 

Elevation 

Representation 

Divided into distinct elevation bands 

(intervals) 
Continuous color gradient without intervals 

Color 

Application 

Specific color for each elevation 

band 

Smooth transition between colors over the full 

elevation range 

Use Case 
Simplified mapping, general terrain 

overview, 

Detailed mapping, precise elevation depiction 

ONLY on modern maps! 

Visual Impact 
Clear and distinct zones, easy to 

differentiate between regions 

More natural and subtle transition, better for 

detailed topography 

Best For 
General topographic maps, large-

scale views 

High-detail topographic maps, scientific 

studies, more accurate elevation representation 

  

These two figures show two types of legend to the hypsometric tint, discrete and continuous tint.  

 
 



 

Contours 
How to create contour lines? 

Data Collection 

Field Surveying: Historically, contour lines were created by field surveyors who would physically 

measure the elevation of specific points on the land using tools like theodolites or levels. They would 

walk across the landscape and take measurements at different points to build up the topographic profile. 

Remote Sensing: Nowadays, satellite data, LiDAR (Light Detection and Ranging), and aerial 

photography provide accurate elevation data over large areas. These technologies scan the surface of the 

Earth and generate digital elevation models (DEMs) or digital terrain models (DTMs). 

Global Positioning System (GPS): GPS-based measurements also help pinpoint exact elevations at 

various points. 

Grid Sampling: The DEM data is divided into a grid, and elevation values are assigned to each grid 

point (or pixel). Each point represents a specific x, y location with an associated elevation (z value). 

Interpolation: To create the contours, the elevation values from the grid are analyzed. Contour lines 

are drawn by finding locations where the terrain crosses specific elevation intervals. For example, if 

contours are drawn every 10 meters, a contour line will be created where the elevation is exactly 10 

meters, another at 20 meters, and so on. 

Manual method: Earlier the contour lines were drawn manually from spot height data and structural 

lines. 

Modern methods: computer algorithms (such as the Marching Squares algorithm) are used to draw 

smooth, continuous contour lines. These lines are drawn at intervals, which can vary based on the map 

scale, the terrain's steepness, and the required detail. Computer algorithms are fast way of contour 

generation, but for a topographic map is not satisfactory. (Missing elevation values, cliff drawing etc.) 

  

Special graphical objects of contour lines 
Index contour: are drawn thicker than regular contour lines to make them more prominent and easier 

to identify. 

Contour interval: topographic maps (large and medium scale maps) uses equal intervals (1, 2, 2.5, 5, 

10, 20, 25 m) geographic maps may do not use equal intervals. 

Contour line value: indicates the elevation above/below sea level 

Cliff lines: are steep slopes or cliffs formed due to erosion or faulting, where there is a dramatic drop in 

elevation. 

Sinkhole: A sinkhole is a low point or hole in the ground, often formed by erosion or collapse. 

Summit: a summit is the highest point of a hill or mountain. 

This topographic map shows a small area, with normal, index(main) contours, contour line values, cliff 

lines and fault lines. 



 

Creating contours in QGIS 
In this Exercise, we will use DTM data to create contour lines at 1 m interval and 5 m interval. 

Load the DTM layer in QGIS. 

 
First, create Contour at 1 m interval. Open the Processing Toolbox → Type here: Contour or Raster 

menu → Extraction → Contour. Run the tool. Set the input elevation layer, the interval to 1 m. Add a 

name to the Attribute field, which will contains the elevation of generated contours. Save the path of the 

output vector file. 



 
 

 
Let’s do the same process again for the 5 m contour interval. 

Set the Symbology and the labels. Set different color for the two contour line layers. Add labels only to 

the 5 m contour interval layer. The labels of the contours have a buffer, that avoids the intersection of 

the label and the line. Buffer color is a white or a very light color, width 0.5-1 mm. The label placement 

is on the line. 



 
 

 
Finally, you can see that we have Normal Contour at 1m interval and Main Contour at 5m interval, and 

we only label Main Contours for enhancing map readability. 

 

Creating Contour Polygons  (using Graduated Symbology for coloring according to 

elev_min value) 
Contour polygon tool create contours from the digital elevation model, but the result are polygons, 

which allows to the users to set coloring to these intervals. This tool can replace the discete coloring of 

the raster. It means displaying a continuous elevation raster (DEM) using separate color classes 

instead of a smooth gradient. Each range of (elevation) gets its own color (e.g., 0–100 m = green, 100–

200 m = yellow, etc.). Contour polygon tool creates filled polygons between contour lines (instead of 

just lines). Each polygon represents an elevation band (e.g., 100–200 m area). This option can be used, 

if you need areas not only lines. 

Create Contour polygons at 5 m interval. Open the Processing Toolbox → Type here: Contour 

polygon. 



 
The settings are basically same as the simple Contour tool. There is only one exception: you have to 

give two names to the fields in the attribute table. These are the lower and the upper edge of the interval 

called elev_min and elev_max. 

 



 
Add a graduated coloring to the layer. Open Symbology → set the render type → Graduated. 

 
Now, edit the color ramp for the visualization to be visually and cartographically appealing. To do this, 

open symbology and edit each color group in Elevation range. 



 
The final result after coloring. 

 

Hill shading 
Hill shading is a technique used in cartography to create the illusion of three-dimensionality on a two-

dimensional map by simulating light and shadow effects on the terrain. It helps to visualize the relief or 

topography of an area, providing a more realistic view of the landscape, especially when used in 

combination with contour lines or hypsometric tints. 

  

The position of the light source (the sun) is critical to hill shading. It is typically positioned at a specific 

angle above the map (usually at an azimuth angle of 45° and an elevation angle of 45° from the 

horizontal). The angle and position of the light source will determine where shadows are cast and 

how the slopes of the terrain appear.  It often uses gray-scale or black-and-white shading to represent 

light and dark areas. 

This image shows a combined hypsometric tint and hill shading. 



 
Why Hill shading analysis maters in GIS and Cartography? 

Support for Spatial Analysis and Decision-Making 

Hill shading isn't just for pretty pictures; it directly supports analytical workflows. 

• Pre-Analysis Exploration: Before running complex slope or watershed analyses, a GIS analyst 

will almost always look at a hill shade first. It provides a quick, qualitative check of the data 

quality and helps form initial hypotheses about the landscape. 

• Feature Identification: 

o Archaeology: Identifying potential burial mounds, hill forts, or terraces that are visible 

as subtle terrain variations. 

o Geology: Mapping faults, folds, and landslides, which often have a distinct topographic 

expression. 

o Urban Planning: Visualizing the impact of terrain on city expansion, sightlines, and 

wind patterns. 

• Line-of-Sight and Visibility Analysis: While precise calculations use the raw DEM, a 

hillshade gives an immediate, intuitive understanding of what areas are visible from a given 

point (e.g., for planning a cell tower or a scenic viewpoint). 

  

Practice in QGIS 
The Raster menu → Analysis → Hill shade or open it from the Processing Toolbox. 

Creating a Hill shade from sample tif. Add the DTM layer and follow the guide in the figures below: 



 
 

 
Now lets analyze the DEM with HCMGIS plugin. 

First, go to QGIS plugin and install plugin HCMGIS in Plugins → Manage and install plugins. Search 

for the plugin, then install it. HCMGIS plugin allows to fit basemaps to the elevation layer surface. For 

this purpose, you also can use QuickMapServices plugin.  



 
Open the plugin and add Google Satellite layer. 

 



 
Now with hill shading and satellite image, these geomorphological features will be better delineated. 

Let’s analyze your Hill shade map. If you compare the hillshading and contour lines, you can recognize 

a valley in the middle of the sample area. 

 



 
 

Hill shading generated in the Symbology menu 

It is also possible to create a hillshading layer in the Layer properties → Symbology → Render type → 

Hillshading. This rendering type uses real-time rendering. That means, if you zoom in, the hill shading 

will be rendered again and again. Be careful, do not use too large zoom level, because sometimes each 

pixels become visible. 

 

Combining hillshading and the hypsometric tint 
You can take visible a hillshading and the hypsometric tint together.  

To do that you need two layers: a layer displayed with hypsometric tint/ or contour polygon layer and a 

hillshade layer. To do that, open the layer Properties Symbology of the hillshading layer. Find the Layer 

rendering and the blending mode is Multiply. You can set the Brightness and the Contrast to set the 

darkness of the image. The hillshading layer have to be the upper layer, because you use the Multiply 

on this layer. 

 
 

 



 

 

3D visualization in QGIS 
First, add Google Satellite map/image view from HCMGIS and DTM layer in your area of interest. 

 
To create a 3D View, go to View → New 3D Map View.   

 
Go to the 3D Configuration menu. To display the elevation layer, click on Terrain and set the Terrain 

type to DEM (Raster Layer) and define the Elevation layer (this is the DEM layer). 

The 3D View will reflect, what you see in the Map Canvas: that means activate those layers in the main 

QGIS window, what you want to see in the 3D View. These layers can vector and raster layers, even 

you can use satellite image layer from Google, or you can fetch OpenStreetMap as well.  

In the Configure, you can modify the 3D scene lightning, and you can modify the vertical exaggeration, 

or you can set another background, and the resolution of the 3D scene. Let’s explore alone these settings!  



 
It will take some minutes to render your 3D view. 

Go to map Canvas and switch off the DTM layer, and Go to 3D view panel, then press (Shift + Left 

click) to navigate your view, you will be able to see something like the figures below: 

(Shift + Left click, then left click+++). 

If you want to save the recent view, click on Save as image, but now it is also possible to Save the whole 

3D scene as 3D model. In this case, QGIS will generate Wavefront OBJ model. 

 
 

Elevation profile 
In this Exercise, we will use DEM data to draw an Elevation profile. 

Before committing massive resources, planners and engineers need to understand the lay of the land. 

• Transportation Routes: Designing roads, railways, and pipelines. 

o Goal: Minimize costly cuts and fills (excavation and embankment), maintain safe 

gradients (slopes), and identify optimal paths. 

o What the profile shows: Steep hills that require switchbacks or tunnels, deep valleys 

that need bridges, and overall earthwork volume. 

• Infrastructure Projects: Planning for power lines, fiber optic cables, or water canals. 



o Goal: Ensure a consistent and functional gradient. A power line must avoid dragging 

on the ground between towers, and a water canal must have a precise, continuous slope. 

o What the profile shows: Sag points for cables and exact slope calculations for gravity-

fed systems. 

  

Add a DEM layer to QGIS, at this stage you will see something like the figure below: 

 
Now to create an Elevation profile. 

Open the View → Elevation Profile submenu. 

 
First, select an elevation layer. Then draw the line or select an existing polyline to the path of the profile. 



 
The profile will be plotted. Save this chart as a PDF or an image file. 

 
If your cursor moves along this path, you can easily identify the elevation and characteristics of the 

profile.  



 

Heatmap 

Heat Maps in QGIS for Crime Data Visualization 
A heatmap is a type of data visualization that uses colors to represent values in a table, grid or map. 

Instead of reading numbers, you quickly understand patterns by looking at color intensity. In maps, this 

technique find out to represent point data density. Generally, the red colors shows those areas, where 

the point density is stronger, blue colors displays low point density. 

In out example, this heatmap in QGIS is a graphical representation of crime density using color 

gradients to show areas of high and low crime concentration. It helps identify crime hotspots, patterns, 

and spatial trends. 

  

In our exercise, we will use Delimited text with geometry. 

Projection: EPSG: 27700 OSGB36/British National Grid 

X field: Easting, Y field: Northing 

  

Open the table as Delimited textfile in QGIS. Layer → Add Layer → Add Delimited Text Layer or in 

DataSource Manager → Find Delimited Tex Layer. 



 
Set the character encoding to UTF-8. Identify the delimiter: it is a comma. In this case, you can use the 

CSV or Custom delimiters (with comma) options as well in the File format section. Set the Geometry 

definition in the next section: these are point coordinates X Field: Easting, Y field: Easting, and the CRS 

is 27700. In the sample data section check, whether you can see the table and data types right way. If 

everything is ok, click Add. 

 
Always check the attribute table after delimited file import.  

Now, explore the dataset! Create a categorization according to the crime type. 



 
In Layer Properties → Symbology → set the render type to Categorized, and the Value is the Crime 

type Column. Colors can help to see, which crime type occured most frequently. To emphasize the 

spatial distribution of the points, we will create a heatmap. In QGIS, there are two ways for that. The 

first one is set the layer render type to heatmap (in Layer Properties → Symbology). This option renders 

the heatmap in real-time. The rendering process can very slow in the case of this large pointset. 

Therefore, in the next example, we will learn, how to generate a raster layer as a heatmap. 

 
Open the Processing toolbox and find Heatmap (Kernel Density Estimation) algorithm.  



  

 
Try to find the best kernel size, set different radius values: 100, 1000, 2000, 5000 (meters) and generate 

four layers! Output raster size: rows: 2000  cols:  around 2300 

In advanced parameters, there are other options to set, now we use the Quartic Kernel shape. 

 
Compare visually the different kernel sizes!  

First, you can see the 100 m radius. This kernel size is too small to this dataset, and the point density is 

not enough to visualize those areas, where the crimes have occured frequently. 



 
This picture shows the 1000 m radius.  

 
This picture shows the 2000 m radius.  

 

 



 
This picture shows the 5000 m radius.  

 
Implications of Changing Heat Map Radius in Crime Analysis 

The radius (bandwidth/search distance) is the most critical parameter in heat map creation. It 

determines the "smoothing" effect and fundamentally changes what patterns you're visualizing. 

  

1. 100 m Radius – Micro-Scale Analysis 

What it shows: 

• Exact hotspot locations (street corners, specific buildings) 

• Micro-clusters within neighborhoods 

• Very localized patterns 

Interpretation: 

• High specificity: Each "hot" spot corresponds to actual crime locations 

• Limited smoothing: Little blurring between nearby points 

• Spotty appearance: May appear as isolated islands of heat 



Use cases: 

• Police deployment: Identifying exact trouble spots for foot patrols 

• Property-level analysis: Specific problem addresses or buildings 

• Tactical operations: Raid planning or targeted interventions 

• Crime prevention through environmental design (CPTED): Site-specific recommendations 

Example findings: 

• "Three adjacent apartment buildings on Maple Street account for 40% of burglaries" 

• "The ATM at 5th and Main has 15 robberies within 100m" 

• "Parking lot behind mall has vehicle theft cluster" 

  

2. 1000 m Radius – Neighborhood Scale 

What it shows: 

• Neighborhood-level patterns 

• Walking distance influence (~10-15 minute walk) 

• Community-scale trends 

Interpretation: 

• Natural smoothing: Balances specificity with pattern recognition 

• Area-based problems: Shows which neighborhoods have systemic issues 

• Common operational scale: Matches many police precinct beat boundaries 

Use cases: 

• Patrol district planning: Resource allocation across neighborhoods 

• Community policing strategies: Area-focused initiatives 

• Social service targeting: Where to locate intervention programs 

• Comparative analysis: Which neighborhoods need priority attention 

Example findings: 

• "The entire downtown entertainment district shows elevated assault rates" 

• "Industrial zone has property crime spread across multiple warehouses" 

• "Residential neighborhood shows dispersed but elevated domestic violence" 

  

3. 2000 m Radius – District/Regional Scale 

What it shows: 

• Broader regional patterns 

• Transit corridor influence (along highways, major roads) 

• Socioeconomic zone correlations 

Interpretation: 

• Significant smoothing: Individual locations blend into area trends 

• Macro-trends: Shows which parts of city have structural problems 

• Policy-level insights: Reveals systemic issues requiring broader solutions 

Use cases: 

• Strategic planning: City-wide resource allocation 

• Policy development: Identifying areas needing economic investment 

• Infrastructure planning: Where to improve lighting, cameras, etc. 

• Inter-agency coordination: Multi-departmental response planning 

Example findings: 

• "Crime follows major transit lines from downtown to suburbs" 

• "Southern district has consistently higher violent crime" 

• "Commercial corridors have different patterns than residential areas" 

  

4. 5000m Radius - City-Wide/Regional Analysis 

What it shows: 

• City-wide gradients 

• Very broad patterns (east vs west, north vs south) 

• Extreme smoothing - essentially shows density gradients 

Interpretation: 

• Minimal local detail: Everything blends together 



• Regional disparities: Shows which parts of metropolitan area have problems 

• Overgeneralization risk: May mask important local variations 

Use cases: 

• Budget justification: High-level presentations to city council 

• Regional comparisons: How your city compares to others 

• Public awareness: Simplified maps for community meetings 

• Academic research: Studying city structure and crime relationships 

Example findings: 

• "Crime decreases consistently from city center outward" 

• "River divides high-crime and low-crime areas" 

• "Metro area shows concentric pattern with downtown peak" 

  

What is a Kernel in Heat Maps? 

A kernel is a mathematical function that determines how influence is distributed from each crime 

point across the surrounding area. Think of it as a "sphere of influence" with varying intensity that 

spreads out from each crime location. 

  

Core Concept: 

Each crime point doesn't just affect its exact location—it influences the surrounding area. The kernel 

defines: 

1. How far this influence spreads (radius/bandwidth) 

2. How intensity decreases with distance 

3. The shape of this influence distribution 

  

How Kernels Work - The "Crime Glow" Analogy 

Imagine each crime point as a light bulb: 

• The kernel type determines the bulb's glow pattern 

• The radius determines how far the light reaches 

• Density is the combined glow from all nearby bulbs 

When crimes cluster, their "glows" overlap, creating brighter (hotter) areas. 

  

1. QUARTIC (Epanechnikov) Kernel 

Mathematical Form: f(d) = (1 - d²)² for d ≤ 1, 0 otherwise where d = distance from point / radius 

Characteristics: 

• Default in QGIS - most commonly used 

• Smooth, dome-shaped distribution 

• Zero influence at radius boundary (sharp cutoff) 

• Moderate smoothing effect 

Crime Analysis Implications: 

• Good general-purpose choice 

• Clear hotspot boundaries - crimes within radius get full consideration 

• No "spillover" beyond radius 

• Predictable results - easy to interpret 

Visual Analogy: Like dropping a heavy stone in water - creates concentrated ripples that stop abruptly 

Best for: General crime mapping, public presentations, operational planning 

  

2. TRIANGULAR Kernel 

Mathematical Form: f(d) = 1 - d for d ≤ 1, 0 otherwise 

Characteristics: 

• Linear decay - influence decreases straight from center to edge 

• Simple weighting - very intuitive 

• Moderate smoothing 

Crime Analysis Implications: 

• Emphasizes proximity - nearby areas get much higher weight 

• Good for catchments - police response times, walking distances 



• Clear distance decay - easy to explain to non-technical audiences 

Visual Analogy: A cone - highest at center, sloping evenly to base edge 

Best for: Service area analysis, response time planning, simple models 

  

3. GAUSSIAN (Normal) Kernel 

Mathematical Form: f(d) = e^(-½d²) (never truly reaches zero) 

Characteristics: 

• Bell curve distribution 

• Theoretically infinite influence (but practically very small beyond 3σ) 

• Very smooth results 

• Statistical foundation - based on normal distribution 

Crime Analysis Implications: 

• Soft boundaries - influence extends beyond nominal radius 

• More natural smoothing - mimics diffusion processes 

• Statistical rigor - preferred for formal analysis 

• Computationally intensive 

Visual Analogy: A campfire's heat - strongest at center but warmth extends far 

Best for: Academic research, risk prediction models, statistical analysis 

  

4. UNIFORM Kernel 

Mathematical Form: f(d) = 1 for d ≤ 1, 0 otherwise 

Characteristics: 

• Constant influence within radius 

• Binary effect - inside radius = full weight, outside = zero 

• "Plateau" shape 

Crime Analysis Implications: 

• Simplistic - all locations within radius treated equally 

• Creates "plateaus" rather than smooth gradients 

• Step-function boundaries - artificial-looking edges 

Visual Analogy: A cylinder - flat top, vertical sides 

Best for: Simple presence/absence analysis, buffer zones, preliminary analysis 

  

5. TRICUBE Kernel 

Mathematical Form: f(d) = (1 - d³)³ for d ≤ 1, 0 otherwise 

Characteristics: 

• Rapid decay near center, very low near edges 

• "Heavy-tailed" - most weight concentrated near point 

Crime Analysis Implications: 

• Emphasizes very local clustering 

• Reduces edge effects - minimal weighting at radius boundary 

• Good for micro-analysis 

Visual Analogy: A steep hill that flattens quickly 

Best for: Micro-hotspot identification, environmental criminology 

  

Practical Implications for Crime Analysis 

How Kernel Choice Affects Your Results: 

Hotspot Definition: 

• Gaussian: Hotspots blend smoothly into surroundings. 

• Quartic: Hotspots have clearer boundaries. 

• Uniform: Hotspots have "hard edges". 

  

 Automatic vectorization 
Find those areas, where the crimes often occurs. Use identify feature on raster, and find the value in 

orange color. The value will depends on the kernel radius size, now we can not say exact value. First, 

find a value in the heatmap_r5000 layer, which is orange. Use Identify features tool. 



 
Then, in Raster → Raster calculator, give the expression (the number should be your value): 

"Heatmap_R5000@1">1500 

Save the image as GeoTiff.  

 



 
The result is a black and white image. It contains two values: 

1: where the original raster value was bigger than the given number (in the example it is 1500). 

0: where the original raster value was lower than the given number 

 
 

Raster–Vector Conversion: Polygonize 
 

Now, this result can be easily converted to a vector layer. QGIS has an automatic vectorization tool in 

Raster → Conversion → Polygonize. The black and white areas will be separately vectorized with this 

tool, the result is a polygon layer.  



 
In the Polygonize menu, set the input raster layer, and give the attribute field name, which will be 

inherited from the raster value. Where the raster pixel value is 1, the attribute is also 1. These are the red 

and orange colored areas. 

 
In the polygon layer, select these areas. Click on Select with an Expression, and give the expression in 

box on the left. Using the predefined attribute field name, the expressing will be something like this: 

„DN”=1. Select the features. 

 



 
Save the selected features as a new layer. Right-click on the layer → Export → Save Selected Features 

As… 

 
The new polygon layer contains the result, where the crimes occur frequently. Check the outline of the 

polygon. If you zoom into the layer, the outline of the polygons looks „stepped”. This is caused by the 

raster image vectorization. The problem is that the polygons outline follows the pixels, and this is an 

unnatural outline of polygons. To take continous this line, a line simplification algorithm is necessary. 



 

Line Simplification with Douglas-Peucker algorithm 
  

Use Processing → Simplify (Distance–Douglas–Peucker) to smooth the line. This tool will remove the 

unnecessary points, and creates a simlified, smoothed line. Give the input layer, and set the tolerance 

value: use 300 (m). 

Read more here about this line simplification algorithm: 

https://en.wikipedia.org/wiki/Ramer%E2%80%93Douglas%E2%80%93Peucker_algorithm 

 

 
The final result looks like the figure below: 

https://en.wikipedia.org/wiki/Ramer%E2%80%93Douglas%E2%80%93Peucker_algorithm


 

Satellite image processing 

What is Copernicus Browser? 
Copernicus Browser is a revolutionary, free, web-based platform developed by the European Space 

Agency (ESA) that fundamentally changes how users access and analyze data from the Copernicus 

program, especially the Sentinel satellites. 

Think of it as a "Google Earth for satellite data," but with powerful analysis tools built directly into your 

web browser, eliminating the need for extensive software and data downloads. 

  

Core Concept 
Its primary purpose is to make the massive, petabyte-scale archives of Copernicus data (particularly 

from the Sentinel-1 radar and Sentinel-2 optical missions) instantly accessible and analyzable online. 

You can visualize, query, and process data directly in the cloud without downloading a single file until 

you need a final result. 

  

Key Features and Capabilities 
1. Instant Visualization & Time Series: Scroll through years of satellite imagery over any 

location on Earth in seconds. You can create time-lapse animations to see changes like urban 

expansion, deforestation, or glacier retreat. 

2. On-the-Fly Analysis (No-Code): This is its most powerful feature. It has a built-in "EO 

Browser Scripts" editor (originally from the Sinergise platform), where you can apply and 

modify pre-written JavaScript code snippets or write your own to: 

• Calculate indices (NDVI for vegetation, NDWI for water, NDBI for built-up areas). 

• Perform classification. 

• Filter and composite imagery (e.g., create cloud-free mosaic). 

• Analyze spectral profiles. 

3. Direct Data Access & Comparison: Seamlessly compare images from different Sentinel 

missions (e.g., radar from Sentinel-1 with optical from Sentinel-2) for the same date and area. 

4. Global, Searchable Archive: A complete, up-to-date catalog of all Sentinel-1, Sentinel-2, 

Sentinel-3, and Sentinel-5P data, plus key third-party datasets (like Landsat 8/9 and EnMAP). 

You can search by location, time, cloud cover, etc. 



5. Integration with Copernicus Data Space Ecosystem: It's the flagship user interface for the 

broader Copernicus Data Space Ecosystem, a new cloud infrastructure that replaced the old 

SciHub. It provides the foundation for all data access and processing. 

6. Sharing and Exporting: Easily share views and analysis scripts with links. You can export 

final processed images (as GeoTIFF, JPEG) or analytical charts, or connect to external tools 

like QGIS or Python via OGC standards (WMS, WCS). 

  

To access Copernicus Browser follow this link https://browser.dataspace.copernicus.eu) 

 
Then select login and register an account. The registration is free, but it is necessary, if you want to 

download satellite images. 

 

https://browser.dataspace.copernicus.eu/


 
Zoom into Budapest. In the box on the left, you are able to visualize satellite images in the browser, and 

in the „Search” section you are able to search and download the desired images. Now, visualize the 

newest satellite image about Budapest city center. Find the today date, and an image where the cloud 

cover is low.  

 
If you have found an appropiate image, try the another layers like NDVI.  

What is NDVI? 
NDVI stands for Normalized Difference Vegetation Index. It’s a simple but powerful metric used in 

satellite imagery and remote sensing to measure how healthy or dense vegetation is in a given area. 

NDVI compares how plants reflect near-infrared light (NIR) and red light: 

• Healthy plants reflect more NIR and absorb more red light (the pixel value close to 1) 

• Unhealthy or sparse vegetation reflects less NIR and more red (the pixel value close to 0) 

The formula NDVI is calculated as: 

NDVI=(NIR+Red)/(NIR−Red) 

  



 
In Copernicus Browser, you are able to save and export georeferenced images, follow the guide below: 

 
Copernicus browser can generate another often used indexes in remote sensing. Try them out, and get 

familiar with this indexes. 

The first option is the visualization of infrared band(s) with RGB colors. False color is an image 

visualization technique where the displayed colors are not the real colors seen by the human eye. Instead, 

colors are assigned to different wavelengths or data values to make features easier to analyze. 



 

NDMI index 
NDMI stands for Normalized Difference Moisture Index. It is a remote sensing index used to estimate 

the moisture content of vegetation and soil using satellite imagery.  

It is especially useful for: 

• drought monitoring 

• crop stress detection 

• forest health analysis 

• wildfire risk assessment 

NDMI formula compares 

NIR = Near-Infrared light 

SWIR = Short-Wave Infrared light 

NDMI=(NIR+SWIR)/(NIR−SWIR) 

Healthy, moist vegetation reflects NIR strongly and absorbs more SWIR. 

 

Scene classification map 
„Scene classification was developed to distinguish between cloudy pixels, clear pixels and water pixels 

of Sentinel-2 data and is a result of ESA's Scene classification algorithm. Twelve different classifications 

are provided including classes of clouds, vegetation, soils/desert, water and snow. It does not constitute 



a land cover classification map in a strict sense.” Read more here: https://custom-scripts.sentinel-

hub.com/sentinel-2/scene-classification/ 

 

Data download 
The second part of the Copernicus Browser is to download raw data for any area and date. Follow the 

guides in the figures below. 

Click on Search. Select the desired area with a polygon and the Sentinel2 satellites. 

 

https://custom-scripts.sentinel-hub.com/sentinel-2/scene-classification/
https://custom-scripts.sentinel-hub.com/sentinel-2/scene-classification/


 
Search raw images, select one of them from the list. 

 
You can get information about the images, click on info button. 



 
In the Info window, you are able to download the image. 

 

How to work with satellite images in QGIS 
Download Sentinel-2A images attached to this sub module and open them in QGIS. Use DataSource 

Manager → Raster layer. 

You can use the satellite image for any area, what you download earlier, or alternatively you can use the 

B2-3-4.zip. B2, B3 and B4 images are representing the blue, green and red band of the Sentinel Satellite 

image. These images are georeferenced and stored in jp2 format, but they are separated layers. In QGIS, 

merge these layers to a multiband image.  

 



 
Merging Sentinel bands in QGIS: Raster → Miscellaneous → Merge. 

 
In the Input layers check all layers, what you need in the result. Check Place each input file to a separate 

band, and set the output file. 



 
The result looks like this: 

 
The order of the bands in the merged file are B2 (1-blue), B3 (2-green) and B4 (3-red)*. If you use 

Multiband color rendering in QGIS, the order of band in this menu are red, green and blue. You can see, 

the red and blue are in reversed order, so the true colors visualization is distorted (see the Lake Balaton 

is displayed with yellow). You have to change the order of red and blue color in the Multiband rendering. 

Now, the Red Band is 3, the Green Band is 2 and Blue Band is 1.  

 

Note: *Why the numbers were changed? The original dataset downloaded from the Copernicus browser 

contained the real band numbers these are 2,3,4. These were the filenames as well. When you merged 

the layers, these layer names were lost, and the image has now 3 bands, these are 1,2,3 but their order 

is the same.  



 
 

Calculate NDVI in QGIS 
Open sentinel_felvetel.tif with Open the Layer with Data Source Manager → Raster. Set the true 

colors, as we learned in the previous chapter. After that, you will see something like this: 



 
NDVI index was discussed earlier. Use sentinel_felvetel.tif to create NDVI layer from this satellite 

image. 

Note: in this image, the red layer is the Band3 and the NIR layer is the Band7. 

Go to Raster → Raster calculator.  

Here, you can  calculate the NDVI index by giving the calculation: 

(sentinel_felvetel@7- sentinel_felvetel@3) / (sentinel_felvetel@7+ sentinel_felvetel@3) 

Save the output layer as GeoTiff. 



 
The result is rendered with Black and white colors. Set a Green color ramp to the NDVI image. Open 

the Layer Properties → Symbology → Render type → Singleband pseudocolor. Interpolation: Linear 

and Color ramp is „Greens”. Apply the settings. 

 

Zonal Statistics 
Use Processing → Zonal Statistics to determine which parcel has the highest average NDVI. 

In this task, you have a vector layer, with some parcels. Calculate the average NDVI for each parcel. 

Use Zonal Statistics. With simple ordering in the result layer attribute table, you are able to find the 

parcel with the strongest (healthy) vegetation.  

Add the parcels Shapefile layer. 



 
Now to calculate Zonal statistics for each polygons. Open in the Processing Toolbox the Zonal Statistics 

algorithm. Set the necessary parameters. Input raster layer is the NDVI layer, input vector layer is the 

parcels Shapefile. In the Statistics to calculate submenu set, which statistical parameters you need. Now, 

we need a mean NDV index for the each polygons, therefor use the Mean (Average).  

 
Open the new result layer’s attribute table, and find the Mean column. Order in descending order, and 

find the highest value. Identify the parcel’s feature ID (fid). 



 
You can also categorize the mean NDVI index of the parcel with Categorize Symbol renderer. It looks 

like this image. Now, you can be able to tell which parcels are stressed and which one are healthier from 

observations based om remote sensing. 

 
 


